7 ноября 2010 г.

Лабораторная работа №15 Configuring VTP Domain with interVLAN Routing курса CISCO CCNA 640 - 802

Лабораторная работа CCNA Cisco Packet Tracer GNS3Целью данной лабораторной работы является настройка VLAN Trunking Protocol ( VTP ) domain с interVLAN маршрутизацией . При выполнении будет использоваться Cisco Packet Tracer 5.3. После выполнения лабораторной работы будут получены базовые навыки настройки VTP на оборудования CISCO, а также закреплены навыки базовой настройки маршрутизаторов Cisco и коммутаторов 2-го уровня Cisco ( Cisco Switches ).


Лабораторная работа CCNA Cisco Packet Tracer GNS3
  
Настройка VTP - домена

1. Настроить основные параметры VTP

2. Добавить VLAN-ы

3. Определить принадлежность портов к VLAN-ам 
4. Определить trunk(-и)  
5. Настроить маршрутизацию между VLAN-ами 

Sw0 
Sw0>enable
Sw0#configure terminal

1. Настроить основные параметры VTP
Sw0(config)#vtp mode server
Sw0(config)#vtp domain CCNA

2. Добавить VLAN-ы
Sw0(config)#vlan 20
Sw0(config-vlan)#name RED
Sw0(config-vlan)#exit
Sw0(config)#vlan 30
Sw0(config-vlan)#name GREEN
Sw0(config-vlan)#exit
Sw0(config)#vlan 40
Sw0(config-vlan)#name BLUE
Sw0(config-vlan)#exit

4. Определить trunk(-и)
Sw0(config)#interface range FastEthernet 0/1-5
Sw0(config-if-range)#switchport mode trunk
Sw0(config-if-range)#end
Sw0#copy run start


Sw1 
Sw1>enable
Sw1#configure terminal
1. Настроить основные параметры VTP
Sw1(config)#vtp mode client

3. Определить принадлежность портов к VLAN-ам
Sw1(config)#interface FastEthernet 0/2
Sw1(config-if)#switchport mode access
Sw1(config-if)#switchport access vlan 20
Sw1(config-if)#exit
Sw1(config)#interface FastEthernet 0/3
Sw1(config-if)#switchport mode access
Sw1(config-if)#switchport access vlan 30
Sw1(config-if)#exit
Sw1(config)#interface FastEthernet 0/4
Sw1(config-if)#switchport mode access
Sw1(config-if)#switchport access vlan 40
Sw1(config-if)#exit

4. Определить trunk(-и)
Sw1(config)#interface FastEthernet 0/1
Sw1(config-if)#switchport mode trunk
Sw1(config-if)#end

Sw1#copy run start

Sw2 
Sw2>enable
Sw2#configure terminal
1. Настроить основные параметры VTP
Sw2(config)#vtp mode client

3. Определить принадлежность портов к VLAN-ам
Sw2(config)#interface FastEthernet 0/2
Sw2(config-if)#switchport mode access
Sw2(config-if)#switchport access vlan 20
Sw2(config-if)#exit
Sw2(config)#interface FastEthernet 0/3
Sw2(config-if)#switchport mode access
Sw2(config-if)#switchport access vlan 30
Sw2(config-if)#exit
Sw2(config)#interface FastEthernet 0/4
Sw2(config-if)#switchport mode access
Sw2(config-if)#switchport access vlan 40
Sw2(config-if)#exit

4. Определить trunk(-и)
Sw2(config)#interface FastEthernet 0/1
Sw2(config-if)#switchport mode trunk
Sw2(config-if)#end
Sw2#copy run start



Sw3 
Sw3>enable
Sw3#configure terminal
1. Настроить основные параметры VTP
Sw3(config)#vtp mode client

3. Определить принадлежность портов к VLAN-ам
Sw3(config)#interface FastEthernet 0/2
Sw3(config-if)#switchport mode access
Sw3(config-if)#switchport access vlan 20
Sw3(config-if)#exit
Sw3(config)#interface FastEthernet 0/3
Sw3(config-if)#switchport mode access
Sw3(config-if)#switchport access vlan 30
Sw3(config-if)#exit
Sw3(config)#interface FastEthernet 0/4
Sw3(config-if)#switchport mode access
Sw3(config-if)#switchport access vlan 40
Sw3(config-if)#exit

4. Определить trunk(-и)
Sw3(config)#interface FastEthernet 0/1
Sw3(config-if)#switchport mode trunk
Sw3(config-if)#end
Sw2#copy run start

Sw4 
Sw3>enable
Sw3#configure terminal
1. Настроить основные параметры VTP
Sw3(config)#vtp mode client

3. Определить принадлежность портов к VLAN-ам
Sw4(config)#interface FastEthernet 0/2
Sw4(config-if)#switchport mode access
Sw4(config-if)#switchport access vlan 20
Sw4(config-if)#exit
Sw4(config)#interface FastEthernet 0/3
Sw4(config-if)#switchport mode access
Sw4(config-if)#switchport access vlan 30
Sw4(config-if)#exit
Sw4(config)#interface FastEthernet 0/4
Sw4(config-if)#switchport mode access
Sw4(config-if)#switchport access vlan 40
Sw4(config-if)#exit

4. Определить trunk(-и)
Sw4(config)#interface FastEthernet 0/1
Sw4(config-if)#switchport mode trunk
Sw4(config-if)#end
Sw4#copy run start


R1
5. Настроить маршрутизацию между VLAN-ами
R1>enableRouter#configure terminal
R1(config)#interface FastEthernet 0/0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface FastEthernet 0/0.20
R1(config-subif)#encapsulation dot1Q 20
R1(config-subif)#ip address 192.168.20.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface FastEthernet 0/0.30
R1(config-subif)#encapsulation dot1Q 30
R1(config-subif)#ip address 192.168.30.1 255.255.255.0
R1(config-subif)#exit
R1(config)#interface FastEthernet 0/0.40
R1(config-subif)#encapsulation dot1Q 40
R1(config-subif)#ip address 192.168.40.1 255.255.255.0
R1(config-subif)#end


R1#copy run start

Диагностика VTP

show vtp status
show vlan
show interfaces trunk

Проверка правильности выполнения лабораторной работы

На PC21 выполняем

ping 192.168.20.1 - default gw

ping 192.168.20.22 - PC22

ping 192.168.20.23 - PC23

ping 192.168.20.24 - PC24

ping 192.168.30.31 - PC31

ping 192.168.30.32 - PC32

ping 192.168.30.33 - PC33

ping 192.168.40.41 - PC41

ping 192.168.40.42 - PC42

ping 192.168.40.43 - PC43

ping 192.168.40.44 - PC44

13 комментариев:

Фай Ро комментирует...

ну vtp не сказать что оч интересен... польза от него только в том что можно быстро разбросать vlan на кучу свичей... но порты все равно на каждом свиче придется вручную конфигурить...
ты кстати не совсем правильно сделал... рекомендуется иметь как минимум 2а свича в режиме vtp сервер, для избыточности и отказоустойчивости, ведь на клиентах нельзя vlan-ы создавать...

Dave комментирует...

если честно, до того как начал готовится к CCNA, мне все что ниже 3-го уровня было не очень интересно... теперь потихоньку разбираюсь. Насчет 2-х свитчей - буду знать...

Фай Ро комментирует...

тем более что VTP цисковский... если придется работать на не-цисковском оборудовании нужно gvrp изучать, а он только в ccnp рассматривается...

Виталий комментирует...

какой Ip у маршрутизатора должен стоять в данном случае? Пытался сделать все тоже самое как у вас только добавил сервер перед маршрутизатором и в SW0 добавил днс сервер. так вот неидут пинги ни на 1 сервер.

Dave комментирует...

Сервер перед маршрутизатором ставить не стоит так как по этому линку идут тэгированные фрэймы, которые будут серверу непонятны. Что каcается сервера в Sw0 - его порт нужно определить в один из VLAN-ов, и назначить соответствующий этому VLAN-у адрес. Т.е. если порт в который воткнут сервер определить в RED, то адрес нужно назначить из 192.168.20.0/24, ну и так далее...

Анонимный комментирует...

В выложенной для скачивания топологии ошибка.
Порт, которым Sw0 подключается к R1 не fa0/5, a fa0/24. Соответственно, его нужно настроить как транк.

deimos комментирует...

Dave,

Мне кажется что указывать vtp mode client не достаточно, так как у Sw0, вы указали Vtp domain. Без указания домена на клиентах, vtp работать не будет. Либо на Sw0 vtp domain стоит сделать пустым.

Dave комментирует...

Если на коммутаторе значение vtp domain равно null и указать режим vtp client, то коммутатор подхватить и имя домена и базу VLAN. В лабораторной работе упоминается именно такой случай.

deimos комментирует...

Dave,

Ты наверное путаешь. Вот это из самого начала конфига этой лабы:
1. Настроить основные параметры VTP
Sw0(config)#vtp mode server
Sw0(config)#vtp domain CCNA

Dave комментирует...

Нет, я не путаю. Я говорил о коммутаторах, которые в этой лабе VTP - клиенты.
В данной лабораторной работе Sw0 конфигурируется как VTP Server, на нем же задается имя VTP домена и необходимые виланы. В данном конкретном случае - это CCNA и виланы RED, GREEN, BLUE. После этого определяются транки. Все остальные коммутаторы настраиваются в режиме VTP Client. На каждом из этих коммутаторов сначала настраивается VTP Mode (Client), а потом определяются транки (F0/1), без указания VTP-домена (т.е. у них значение VTP Domain Name is null ). Как только будет введена команда switchport mode trunk для интерфейса F0/1, сразу же коммутатор подхватит и имя домена и все виланы. Это легко можно проверить, выполнив данную лабораторную работу.

Dave комментирует...

Вот кстати где ошибка в лабораторной работе, так это то, что при настройке Sw1, Sw2, Sw3 и Sw4, пункты 3 и 4 нужно поменять местами. Сначала нужно определять транки, а потом определять аксес порты в виланы. В обратном порядке не получится. Виланов просто еще не будет у свитча, а создать он их не сможет так как режим VTP Client.

deimos комментирует...

Dave,

Спасибо за комментарии, совершенно верно.
Выполнил лабу, потренировался на кошках :)
Всё работает как ты и описал, что касается очерёдности, то транки надо указывать первыми.

Dave комментирует...

Всегда пожалуйста.

Отправить комментарий