12 марта 2013 г.

Лабораторная работа CCNA #FastPass - VLAN Lab 1 Basics

Лабораторная работа CCNA #FastPass - VLAN Lab 1 Basics
Лабораторная работа CCNA по теме VLAN.  Данная лабораторная работа может быть выполнена на реальном оборудовании  или в Cisco Packet Tracer.  Все необходимые действия указаны по порядку их выполнения. Для начала выполнения лабораторной работы необходимо соединить физическую сеть в соответствии со схемой сети или построить соответствующий проект в Cisco Packet Tracer.  Сразу после схемы сети в таблице указана схема адресация, которую нужно применять только тогда, когда это будет явно указано в тексте лабораторной работы. 

Используемая топология

Лабораторная работа CCNA #FastPass - VLAN Lab 1 Basics

 План адресации
Device
Interface
IP Address
Subnet Mask
Default Gateway
S1
VLAN 99
192.168.99.11
255.255.255.0
N/A
S2
VLAN 99
192.168.99.12
255.255.255.0
N/A
S3
VLAN 99
192.168.99.13
255.255.255.0
N/A
PC1
NIC
192.168.10.21
255.255.255.0
192.168.10.1
PC2
NIC
192.168.20.22
255.255.255.0
192.168.20.1
PC3
NIC
192.168.30.23
255.255.255.0
192.168.30.1
PC4
NIC
192.168.10.24
255.255.255.0
192.168.10.1
PC5
NIC
192.168.20.25
255.255.255.0
192.168.20.1
PC6
NIC
192.168.30.26
255.255.255.0
192.168.30.1
 Назначения портов (S1 и S2)
Port
Assignment
Network
Fa0/1 – 0/5
802.1q Trunks (Native VLAN 99)
192.168.99.0 /24
Fa0/6 – 0/10
VLAN 30 – Red
192.168.30.0 /24
Fa0/11 – 0/17
VLAN 10 – Green
192.168.10.0 /24
Fa0/18 – 0/24
VLAN 20 – Amber
192.168.20.0 /24
 

1. Базовая конфигурация оборудования
·         Настроить hostname.
·         Отключить DNS lookup.
·         Установить пароль для  EXEC mode
·         Настроить message-of-the-day banner.
·         Установить пароль для console

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#enable secret class
S1(config)#no ip domain-lookup
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]


·         Активировать пользовательские порты на  S2 и S3.
Настройить пользовательские порты в режиме  access  в соответствии со схемой

S2(config)#interface range fa0/6, fa0/11, fa0/18
S2(config-if-range)#switchport mode access
S2(config-if-range)#no shutdown

S3(config)#interface range fa0/6, fa0/11, fa0/18
S3(config-if-range)#switchport mode access
S3(config-if-range)#no shutdown

2. Настроить Ethernet интерфейсы персональных компьютеров
Настроить  сетевые интерфейсы PC1, PC2, PC3, PC4, PC5 и PC6 в соответствии с планом адресации.

3. Настроить VLAN-ы на коммутаторах
·         На каждом из коммутаторов ( S1, S2 и S3)  настроить VLAN-ы, как показано в примере ниже

S1(config)#vlan 99
S1(config-vlan)#name management
S1(config-vlan)#exit
S1(config)#vlan 10
S1(config-vlan)#name Green
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name Amber
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name Red
S1(config-vlan)#exit

·         Проверить выполненные действия на каждом из коммутаторов командой show vlan brief
S1#show vlan brief

VLAN Name          Status Ports
---- ------------------------------- --------- -----------------------------
1 default         active Fa0/1, Fa0/2, Fa0/4, Fa0/5
Fa0/6, Fa0/7, Fa0/8, Fa0/9
Fa0/10, Fa0/11, Fa0/12, Fa0/13
Fa0/14, Fa0/15, Fa0/16, Fa0/17
Fa0/18, Fa0/19, Fa0/20, Fa0/21
Fa0/22, Fa0/23, Fa0/24, Gi0/1
Gi0/2
10   Green                      active
20   Amber                            active
30   Red                                active
99   management                          active


·         На коммутаторах S1 и S2 назначить порты соответствующим VLAN согласно таблицы назначения портов.

S3(config)#interface range fa0/6-10
S3(config-if-range)#switchport access vlan 30
S3(config-if-range)#interface range fa0/11-17
S3(config-if-range)#switchport access vlan 10
S3(config-if-range)#interface range fa0/18-24
S3(config-if-range)#switchport access vlan 20
S3(config-if-range)#end
S3#copy running-config startup-config
Destination filename [startup-config]? [enter]
Building configuration...
[OK]

·         Проверить выполненные настройки командой show vlan id vlan-number.

·         Настроить IP-адреса для интерфейсов управления на S1, S2 и S3 .

S1(config)#interface vlan 99
S1(config-if)#ip address 192.168.99.11 255.255.255.0
S1(config-if)#no shutdown
S2(config)#interface vlan 99
S2(config-if)#ip address 192.168.99.12 255.255.255.0
S2(config-if)#no shutdown
S3(config)#interface vlan 99
S3(config-if)#ip address 192.168.99.13 255.255.255.0

·         На каждом из коммутаторов настроить trunk-порты и native VLAN

S1(config)#interface range fa0/1-5
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#switchport trunk native vlan 99
S1(config-if-range)#no shutdown
S1(config-if-range)#end

S2(config)# interface range fa0/1-5
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#switchport trunk native vlan 99
S2(config-if-range)#no shutdown
S2(config-if-range)#end

S3(config)# interface range fa0/1-5
S3(config-if-range)#switchport mode trunk
S3(config-if-range)#switchport trunk native vlan 99
S3(config-if-range)#no shutdown
S3(config-if-range)#end

Проверить выполненные действия командой show interface trunk

4. Проверить наличие связи в сети
·         Из консоли коммутатора  S1, выполнить команду ping для интерфейсов  управления S2 and S3.

S1#ping 192.168.99.12
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.12, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms

S1#ping 192.168.99.13
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.99.13, timeout is 2 seconds:
.!!!!
Success rate is 80 percent (4/5), round-trip min/avg/max = 1/1/1 ms

·         На PC1 выполнить команду ping для PC4, PC2 -> PC5, PC3->PC6.

3 комментария:

Анонимный комментирует...

Неправильно указана задача:

Назначения портов (S1 и S2)
на
Назначения портов (S2 и S3)

Руслан комментирует...

Не верная команда - S1(config-line)#line vty 0 15
Правильная команда - S1(config)#line vty 0 15

Анонимный комментирует...

Руслан, вы ошибаетесь, все написано верно - из режимов конфигурации интерфейсов в режим конф. других интерфейсов один из вариантов перехода именно такой

Единственное, что я не понял - зачем в начальных данных конечным хостам прописывать адрес шлюза - ведь его нигде нет)))
Достаточно Ip и маски - и все прекрасно работает))

Отправить комментарий