13 марта 2013 г.

Лабораторная работа CCNA #FastPass - VTP Lab 1 Basics

Лабораторная работа CCNA #FastPass - VTP Lab 1 Basics
Лабораторная работа CCNA по теме VTP.  Данная лабораторная работа может быть выполнена на реальном оборудовании  или в Cisco Packet Tracer.  Все необходимые действия указаны по порядку их выполнения. Для начала выполнения лабораторной работы необходимо соединить физическую сеть в соответствии со схемой сети или построить соответствующий проект в Cisco Packet Tracer.  Сразу после схемы сети в таблице указана схема адресация, которую нужно применять только тогда, когда это будет явно указано в тексте лабораторной работы. 

Используемая топология

Лабораторная работа CCNA #FastPass - VTP Lab 1 Basics

 План адресации
Device
Interface
IP Address
Subnet Mask
Default Gateway
S1
VLAN 99
172.17.99.11
255.255.255.0
N/A
S2
VLAN 99
172.17.99.12
255.255.255.0
N/A
S3
VLAN 99
172.17.99.13
255.255.255.0
N/A
PC1
NIC
172.17.10.21
255.255.255.0
172.17.10.1
PC2
NIC
172.17.20.22
255.255.255.0
172.17.20.1
PC3
NIC
172.17.30.23
255.255.255.0
172.17.30.1
PC4
NIC
172.17.10.24
255.255.255.0
172.17.10.1
PC5
NIC
172.17.20.25
255.255.255.0
172.17.20.1
PC6
NIC
172.17.30.26
255.255.255.0
172.17.30.1
 Назначения портов (S1 и S2)
Port
Assignment
Network
Fa0/1 – 0/5
802.1q Trunks (Native VLAN 99)
172.17.99.0 /24
Fa0/6 – 0/10
VLAN 30 – Red
172.17.30.0 /24
Fa0/11 – 0/17
VLAN 10 – Green
172.17.10.0 /24
Fa0/18 – 0/24
VLAN 20 – Amber
172.17.20.0 /24
 

1. Базовая конфигурация оборудования
·         Настроить hostname.
·         Отключить DNS lookup.
·         Установить пароль для  EXEC mode
·         Настроить message-of-the-day banner.
·         Установить пароль для console

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#enable secret class
S1(config)#no ip domain-lookup
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]


·         Активировать пользовательские порты на  S2 и S3.
Настройить пользовательские порты в режиме  access  в соответствии со схемой

S2(config)#interface fa0/6
S2(config-if)#switchport mode access
S2(config-if)#no shutdown
S2(config-if)#interface fa0/11
S2(config-if)#switchport mode access
S2(config-if)#no shutdown
S2(config-if)#interface fa0/18
S2(config-if)#switchport mode access
S2(config-if)#no shutdown

S3(config)#interface fa0/6
S3(config-if)#switchport mode access
S3(config-if)#no shutdown
S3(config-if)#interface fa0/11
S3(config-if)#switchport mode access
S3(config-if)#no shutdown
S3(config-if)#interface fa0/18
S3(config-if)#switchport mode access
S3(config-if)#no shutdown

·         Активировать trunk -порты на S1, S2 и S3

S1(config)#interface fa0/1
S1(config-if)#no shutdown
S1(config)#interface fa0/2
S1(config-if)#no shutdown

S2(config)#interface fa0/1
S2(config-if)#no shutdown

S3(config)#interface fa0/2
S3(config-if)#no shutdown


2. Настроить Ethernet интерфейсы персональных компьютеров
Настроить  сетевые интерфейсы PC1, PC2, PC3, PC4, PC5 и PC6 в соответствии с планом адресации.  Используя команду ping, убедится в наличии связи между PC1 и PC4,  PC2 и PC5, а также между PC3 и PC6. 

3. Настроить VTP на свитчах
·         Используя команду  show vtp status проверить текущие настройки коммутаторов

S1#show vtp status
VTP Version       : 2
Configuration Revision   : 0
Maximum VLANs supported locally : 255
Number of existing VLANs  : 5
VTP Operating Mode     : Server
VTP Domain Name      :
VTP Pruning Mode     : Disabled
VTP V2 Mode       : Disabled
VTP Traps Generation    : Disabled
MD5 digest        : 0x57 0xCD 0x40 0x65 0x63 0x59 0x47 0xBD
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)

S2#show vtp status
VTP Version       : 2
Configuration Revision   : 0
Maximum VLANs supported locally : 255
Number of existing VLANs  : 5
VTP Operating Mode     : Server
VTP Domain Name      :
VTP Pruning Mode     : Disabled
VTP V2 Mode       : Disabled
VTP Traps Generation    : Disabled
MD5 digest        : 0x57 0xCD 0x40 0x65 0x63 0x59 0x47 0xBD
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)

S3#show vtp status
VTP Version       : 2
Configuration Revision   : 0
Maximum VLANs supported locally : 255
Number of existing VLANs  : 5
VTP Operating Mode     : Server
VTP Domain Name      :
VTP Pruning Mode     : Disabled
VTP V2 Mode       : Disabled
VTP Traps Generation    : Disabled
MD5 digest        : 0x57 0xCD 0x40 0x65 0x63 0x59 0x47 0xBD
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Коммутаторы S1, S2 и S3 находятся в режиме Server. Это является настройками по умолчанию для большинства коммутаторов Catalyst

·         Настроить operating mode, domain name, и VTP password на всех коммутаторах

S1(config)#vtp mode server
Device mode already VTP SERVER.
S1(config)#vtp domain VtpLab
Changing VTP domain name from NULL to VtpLab
S1(config)#vtp password cisco
Setting device VLAN database password to cisco
S1(config)#end

S2(config)#vtp mode client
Setting device to VTP CLIENT mode
S2(config)#vtp domain VtpLab
Changing VTP domain name from NULL to VtpLab
S2(config)#vtp password cisco
Setting device VLAN database password to cisco
S2(config)#end

S3(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.
S3(config)#vtp domain VtpLab
Changing VTP domain name from NULL to VtpLab
S3(config)#vtp password cisco
Setting device VLAN database password to cisco
S3(config)#end

·         Сконфигурировать native VLAN для trunk портов на всех коммутаторах
Для упрощения процесса необходимо использовать команду interface range

S1(config)#interface range fa0/1-5
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#switchport trunk native vlan 99
S1(config-if-range)#no shutdown
S1(config-if-range)#end

S2(config)# interface range fa0/1-5
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#switchport trunk native vlan 99
S2(config-if-range)#no shutdown
S2(config-if-range)#end

S3(config)# interface range fa0/1-5
S3(config-if-range)#switchport mode trunk
S3(config-if-range)#switchport trunk native vlan 99
S3(config-if-range)#no shutdown
S3(config-if-range)#end

·         Настроить  port security для  access layer коммутаторов  S2 и S3
Для портов  fa0/6, fa0/11 и  fa0/18 установить ограничение в одно подключение. Аппаратный адрес  подключенного интерфейса должен быть получен динамически.

S2(config)#interface fa0/6
S2(config-if)#switchport port-security
S2(config-if)#switchport port-security maximum 1
S2(config-if)#switchport port-security mac-address sticky
S2(config-if)#interface fa0/11
S2(config-if)#switchport port-security
S2(config-if)#switchport port-security  maximum 1
S2(config-if)#switchport port-security mac-address sticky
S2(config-if)#interface fa0/18
S2(config-if)#switchport port-security
S2(config-if)#switchport port-security  maximum 1
S2(config-if)#switchport port-security mac-address sticky
S2(config-if)#end

S3(config)#interface fa0/6
S3(config-if)#switchport port-security
S3(config-if)#switchport port-security maximum 1
S3(config-if)#switchport port-security mac-address sticky
S3(config-if)#interface fa0/11
S3(config-if)#switchport port-security
S3(config-if)#switchport port-security  maximum 1
S3(config-if)#switchport port-security mac-address sticky
S3(config-if)#interface fa0/18
S3(config-if)#switchport port-security
S3(config-if)#switchport port-security  maximum 1
S3(config-if)#switchport port-security mac-address sticky
S3(config-if)#end

·         Настроить  VLAN-ы  на  VTP сервере

VLAN 99 (management)
VLAN 10 (Green)
VLAN 20 (Amber)
VLAN 30 (Red)

S1(config)#vlan 99
S1(config-vlan)#name management
S1(config-vlan)#exit
S1(config)#vlan 10
S1(config-vlan)#name Green
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name Amber
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name Red
S1(config-vlan)#exit

Проверить выполненные действия командой show vlan brief

·         Проверить  распространение созданных VLAN-ов на  S2 и S3
Используя команду show vlan brief  на S2 и S3, убедится в том, что созданные на VTP-сервере VLAN-ы были распределены на все коммутаторы.

S2#show vlan brief
VLAN Name                              Status    Ports
---- -------------------------------- --------- -----------------------------
1   default                           active    Fa0/1, Fa0/2, Fa0/4, Fa0/5
 Fa0/6, Fa0/7, Fa0/8, Fa0/9
 Fa0/10, Fa0/11, Fa0/12,Fa0/13
 Fa0/14, Fa0/15, Fa0/16,Fa0/17
 Fa0/18, Fa0/19, Fa0/20,Fa0/21
 Fa0/22, Fa0/23, Fa0/24, Gi0/1
 Gi0/2
10   Green                       active
20   Amber                             active
30   Red                               active
99   management                        active

S3#show vlan brief
VLAN Name                              Status    Ports
---- -------------------------------- --------- -----------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5
 Fa0/6, Fa0/7, Fa0/8, Fa0/9
 Fa0/10, Fa0/11, Fa0/12,Fa0/13
 Fa0/14, Fa0/15, Fa0/16,Fa0/17
 Fa0/18, Fa0/19, Fa0/20,Fa0/21
 Fa0/22, Fa0/23, Fa0/24, Gi0/1
 Gi0/2
1002 fddi-default                      act/unsup
1003 token-ring-default                act/unsup
1004 fddinet-default                   act/unsup
1005 trnet-default                     act/unsup

·         Создать новый  VLAN на S2 и S3.

S2(config)#vlan 88
%VTP VLAN configuration not allowed when device is in CLIENT mode.

S3(config)#vlan 88
S3(config-vlan)#name test
S3(config-vlan)#

Удалить  VLAN 88 на S3.

S3(config)#no vlan 88

·         Настроить  VLAN-ы  на  S3

VLAN 99 (management)
VLAN 10 (Green)
VLAN 20 (Amber)
VLAN 30 (Red)

S1(config)#vlan 99
S1(config-vlan)#name management
S1(config-vlan)#exit
S1(config)#vlan 10
S1(config-vlan)#name Green
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name Amber
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name Red
S1(config-vlan)#exit


·         Настроить IP-адреса для интерфейсов управления на S1, S2 и S3 .

S1(config)#interface vlan 99
S1(config-if)#ip address 172.17.99.11 255.255.255.0
S1(config-if)#no shutdown

S2(config)#interface vlan 99
S2(config-if)#ip address 172.17.99.12 255.255.255.0
S2(config-if)#no shutdown

S3(config)#interface vlan 99
S3(config-if)#ip address 172.17.99.13 255.255.255.0
S3(config-if)#no shutdown

·         Назначить порты соотвествующим VLAN согласно таблицы назначения портов.

S3(config)#interface range fa0/6-10
S3(config-if-range)#switchport access vlan 30
S3(config-if-range)#interface range fa0/11-17
S3(config-if-range)#switchport access vlan 10
S3(config-if-range)#interface range fa0/18-24
S3(config-if-range)#switchport access vlan 20
S3(config-if-range)#end
S3#copy running-config startup-config
Destination filename [startup-config]? [enter]
Building configuration...
[OK]


4. Настроить VTP Pruning
VTP Pruning  настраивается в global configuration mode командой vtp pruning для коммутаторов в  Server VTP Operating Mode.

S1#show vtp status
VTP Version       : 2
Configuration Revision   : 0
Maximum VLANs supported locally : 255
Number of existing VLANs  : 5
VTP Operating Mode     : Server
VTP Domain Name      : VtpLab
VTP Pruning Mode     : Enabled

2 комментария:

Анонимный комментирует...

Насколько я понимаю, команда vtp pruning в PacketTracer отсутствует?

Анонимный комментирует...

насколько я понял - да =)
сам сегодня эту же лабу делал на CPT

вот здесь обнаружил быстрое и доступное объяснение vtp-prunung, кстати:
https://www.youtube.com/watch?feature=player_embedded&v=N8IyCBMKEIU

Отправить комментарий