14 марта 2013 г.

Лабораторная работа CCNA #FastPass - STP Lab 1 Basics

Лабораторная работа CCNA #FastPass - STP Lab 1 Basics
Лабораторная работа CCNA по теме STP.  Данная лабораторная работа может быть выполнена на реальном оборудовании  или в Cisco Packet Tracer.  Все необходимые действия указаны по порядку их выполнения. Для начала выполнения лабораторной работы необходимо соединить физическую сеть в соответствии со схемой сети или построить соответствующий проект в Cisco Packet Tracer.  Сразу после схемы сети в таблице указана схема адресация, которую нужно применять только тогда, когда это будет явно указано в тексте лабораторной работы. 

Используемая топология

Лабораторная работа CCNA #FastPass - STP Lab 1 Basics

 План адресации
Device
Interface
IP Address
Subnet Mask
Default Gateway
S1
VLAN 1
172.17.10.1
255.255.255.0
N/A
S2
VLAN 1
172.17.10.2
255.255.255.0
N/A
S3
VLAN 1
172.17.10.3
255.255.255.0
N/A
S4
VLAN 1
172.17.10.4
255.255.255.0
N/A




1. Базовая конфигурация оборудования
·         Настроить hostname.
·         Отключить DNS lookup.
·         Установить пароль для  EXEC mode
·         Настроить message-of-the-day banner.
·         Установить пароль для console

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#enable secret class
S1(config)#no ip domain-lookup
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1
S2(config)#enable secret class
S2(config)#no ip domain-lookup
S2(config)#line console 0
S2(config-line)#password cisco
S2(config-line)#login
S2(config-line)#line vty 0 15
S2(config-line)#password cisco
S2(config-line)#login
S2(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1
S3(config)#enable secret class
S3(config)#no ip domain-lookup
S3(config)#line console 0
S3(config-line)#password cisco
S3(config-line)#login
S3(config-line)#line vty 0 15
S3(config-line)#password cisco
S3(config-line)#login
S3(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1
S4(config)#enable secret class
S4(config)#no ip domain-lookup
S4(config)#line console 0
S4(config-line)#password cisco
S4(config-line)#login
S4(config-line)#line vty 0 15
S4(config-line)#password cisco
S4(config-line)#login
S4(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S4#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

·         Активировать пользовательские порты на каждом из коммутаторов.

S1(config)#interface range fa0/4-24
S1(config-if-range)#switchport mode access
S1(config-if-range)#no shutdown

S2(config)#interface range fa0/4-24
S2(config-if-range)#switchport mode access
S2(config-if-range)#no shutdown

S3(config)#interface range fa0/4-24
S3(config-if-range)#switchport mode access
S3(config-if-range)#no shutdown

S4(config)#interface range fa0/4-24
S4(config-if-range)#switchport mode access
S4(config-if-range)#no shutdown

·         На каждом из коммутаторов настроить trunk-порты

S1(config-if-range)#interface range fa0/1-3
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#no shutdown

S2(config-if-range)#interface range fa0/1-3
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#no shutdown

S3(config-if-range)#interface range fa0/1-3
S3(config-if-range)#switchport mode trunk
S3(config-if-range)#no shutdown

S4(config-if-range)#interface range fa0/1-3
S4(config-if-range)#switchport mode trunk
S4(config-if-range)#no shutdown


·         Настроить IP-адреса для интерфейсов управления на S1, S2, S3 и S4.

S1(config)#interface vlan1
S1(config-if)#ip address 172.17.10.1 255.255.255.0
S1(config-if)#no shutdown

S2(config)#interface vlan1
S2(config-if)#ip address 172.17.10.2 255.255.255.0
S2(config-if)#no shutdown

S3(config)#interface vlan1
S3(config-if)#ip address 172.17.10.3 255.255.255.0
S3(config-if)#no shutdown

S4(config)#interface vlan1
S4(config-if)#ip address 172.17.10.4 255.255.255.0
S4(config-if)#no shutdown

2. Настроить Spanning Tree
·         На каждом из коммутаторов ( S1, S2, S3 и S4)  проверить текущую конфигурацию командой show spanning-tree

S1#show spanning-tree
VLAN0001
    Spanning tree enabled protocol ieee
    Root ID Priority  32769
                 Address
cc00.0ca0.0000
                 Cost 19
                 Port 1(FastEthernet0/1)
                 Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
                 Address
cc03.0ca0.0000
                 Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
                 Aging Time 20

Interface                Role Sts    Cost          Prio.Nbr  Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1                    Desg FWD    19            128.1     P2p
Fa0/2                    Root FWD    19            128.2     P2p
Fa0/3                    Desg FWD    19            128.3     P2p

S2#show spanning-tree
VLAN0001
    Spanning tree enabled protocol ieee
    Root ID Priority 32769
                 Address cc00.0ca0.0000
                 Cost 19
                 Port 3(FastEthernet0/3)
                 Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
                 Address cc02.0ca0.0000
                 Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
                 Aging Time 20

Interface                Role Sts    Cost          Prio.Nbr  Type
---------------- ---- --- --------- -------- -------------------------
Fa0/1                    Altn BLK    19            128.1     P2p
Fa0/2                    Desg FWD    19            128.2     P2p
Fa0/3                    Root FWD    19            128.3     P2p

S3#show spanning-tree
VLAN0001

    Spanning tree enabled protocol ieee
    Root ID Priority 32769
                 Address cc00.0ca0.0000
                 Cost 19
                 Port 2(FastEthernet0/2)
                 Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
                 Address cc01.0ca0.0000

                 Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
                 Aging Time 20

Interface                Role Sts    Cost          Prio.Nbr  Type
---------------- ---- --- --------- -------- ---------------------------
Fa0/1                    Root  FWD    19            128.2     P2p
Fa0/2                    Altn  BLK    19            128.1     P2p
Fa0/3                    Altn  BLK    19            128.3     P2p

S4#show spanning-tree
VLAN0001
    Spanning tree enabled protocol ieee
    Root ID Priority 32769
                 Address cc00.0ca0.0000
                 This bridge is the root
                 Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

    Bridge ID Priority 32769 (priority 32768 sys-id-ext 1)
                Address cc00.0ca0.0000
                Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
                Aging Time 20

Interface                Role Sts    Cost          Prio.Nbr  Type
---------------- ---- --- --------- -------- --------------------------
Fa0/1                    Desg FWD    19            128.1     P2p
Fa0/2                    Desg FWD    19            128.2     P2p
Fa0/3                    Desg FWD    19            128.3     P2p



3. Наблюдение поведения оборудования при изменении топологии
·         На каждом из коммутаторов ( S1, S2 и S3)  включить режим отладки протокола STP командой debug spanning-tree events.

S1#debug spanning-tree events
Spanning Tree event debugging is on

S2#debug spanning-tree events
Spanning Tree event debugging is on

S3#debug spanning-tree events
Spanning Tree event debugging is on


·         На корневом коммутаторе ( в данном примере S4 ) умышленно отключить один из trunk-портов
S4(config)#interface fa0/3
S4(config-if)#shutdown


S1#
*Mar 1 10:24:53.125: STP: VLAN1 Fa0/3 -> listening
*Mar 1 10:24:53.225: STP: VLAN1 Fa0/2 -> listening
*Mar 1 10:24:54.165: STP: VLAN1 heard root 32768-cc02.0ca0.0000 on Fa0/3
*Mar 1 10:24:54.169: current Root has 32768-cc00.0ca0.0000
*Mar 1 10:24:54.241: STP: VLAN1 heard root 32768-cc01.0ca0.0000 on Fa0/2
*Mar 1 10:24:54.245: current Root has 32768-cc00.0ca0.0000
*Mar 1 10:24:54.253: STP: VLAN1 Topology Change rcvd on Fa0/3
*Mar 1 10:24:54.257: STP: VLAN1 sent Topology Change Notice on Fa0/1
*Mar 1 10:24:54.293: STP: VLAN1 Topology Change rcvd on Fa0/2
*Mar 1 10:25:08.145: STP: VLAN1 Fa0/3 -> learning
*Mar 1 10:25:08.249: STP: VLAN1 Fa0/2 -> learning
*Mar 1 10:25:23.189: STP: VLAN1 sent Topology Change Notice on Fa0/1
*Mar 1 10:25:23.189: STP: VLAN1 Fa0/3 -> forwarding
*Mar 1 10:25:23.293: STP: VLAN1 sent Topology Change Notice on Fa0/1
*Mar 1 10:25:23.293: STP: VLAN1 Fa0/2 -> forwarding
S2#
*Mar 1 10:24:43.653: STP: VLAN1 Fa0/1 -> listening
*Mar 1 10:24:44.521: STP: VLAN1 we are the spanning tree root
*Mar 1 10:24:44.541: STP: VLAN1 heard root 32768-cc00.0ca0.0000 on Fa0/3
*Mar 1 10:24:44.545: current Root has 32768-cc02.0ca0.0000
*Mar 1 10:24:44.545: supersedes 32768-cc02.0ca0.0000
*Mar 1 10:24:44.549: STP: VLAN1 new root is 32768, cc00.0ca0.0000 on port Fa0/3, cost 38
*Mar 1 10:24:44.549: STP: VLAN1 sent Topology Change Notice on Fa0/3
*Mar 1 10:24:45.597: STP: VLAN1 Fa0/1 -> blocking
S3#
*Mar 1 10:24:24.921: STP: VLAN1 heard root 32768-cc02.0ca0.0000 on Fa0/2
*Mar 1 10:24:24.925: current Root has 32768-cc00.0ca0.0000
*Mar 1 10:24:24.973: STP: VLAN1 we are the spanning tree root
*Mar 1 10:24:25.097: STP: VLAN1 heard root 32768-cc00.0ca0.0000 on Fa0/1
*Mar 1 10:24:25.097: current Root has 32768-cc01.0ca0.0000
*Mar 1 10:24:25.097: supersedes 32768-cc01.0ca0.0000
*Mar 1 10:24:25.097: STP: VLAN1 new root is 32768, cc00.0ca0.0000 on port Fa0/1, cost 38
*Mar 1 10:24:25.097: STP: VLAN1 sent Topology Change Notice on Fa0/1

2 комментария:

Анонимный комментирует...

Доброго времени суток!
Можно ли уточнить на каких коммутаторах делается лабораторная. Дело в том, что команды:
S1#debug spanning-tree events
нет на коммутаторе в PT
Cisco WS-C2960-24TT
S1#debug ?
ip IP information
sw-vlan vlan manager

Dave комментирует...

К сожелению в Cisco Packet Tracer нет многих команд. Лабораторная работа изначально рассчитана на реальное оборудование. Если нет доступа к таковому, то рекомендую воспользоваться беплатным рэком. На стене группы в ВК два последних сообщения посвящены как раз бесплатным рэкам. В предпоследнем сообщении как раз описывается рэк из 8 коммутаторов Cisco с бесплатным дотупом.

Отправить комментарий