15 марта 2013 г.

Лабораторная работа CCNA #FastPass - STP Lab 2 Advanced

Лабораторная работа CCNA #FastPass - STP Lab 2 Advanced
Лабораторная работа CCNA по теме STP.  Данная лабораторная работа может быть выполнена на реальном оборудовании  или в Cisco Packet Tracer.  Все необходимые действия указаны по порядку их выполнения. Для начала выполнения лабораторной работы необходимо соединить физическую сеть в соответствии со схемой сети или построить соответствующий проект в Cisco Packet Tracer.  Сразу после схемы сети в таблице указана схема адресация, которую нужно применять только тогда, когда это будет явно указано в тексте лабораторной работы. 

Используемая топология
Лабораторная работа CCNA #FastPass - STP Lab 2 Advanced


План адресации
Device
Interface
IP Address
Subnet Mask
Default Gateway
S1
VLAN 99
192.168.99.11
255.255.255.0
N/A
S2
VLAN 99
192.168.99.12
255.255.255.0
N/A
S3
VLAN 99
192.168.99.13
255.255.255.0
N/A
PC1
NIC
192.168.10.21
255.255.255.0
192.168.10.1
PC2
NIC
192.168.20.22
255.255.255.0
192.168.20.1
PC3
NIC
192.168.30.23
255.255.255.0
192.168.30.1
PC4
NIC
192.168.10.24
255.255.255.0
192.168.10.1
PC5
NIC
192.168.20.25
255.255.255.0
192.168.20.1
PC6
NIC
192.168.30.26
255.255.255.0
192.168.30.1
 Назначения портов (S1 и S2)
Port
Assignment
Network
Fa0/1 – 0/5
802.1q Trunks (Native VLAN 99)
192.168.99.0 /24
Fa0/6 – 0/10
VLAN 30 – Red
192.168.30.0 /24
Fa0/11 – 0/17
VLAN 10 – Green
192.168.10.0 /24
Fa0/18 – 0/24
VLAN 20 – Blue
192.168.20.0 /24






1. Базовая конфигурация оборудования
·         Настроить hostname.
·         Отключить DNS lookup.
·         Установить пароль для  EXEC mode
·         Настроить message-of-the-day banner.
·         Установить пароль для console

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#hostname S1
S1(config)#enable secret class
S1(config)#no ip domain-lookup
S1(config)#line console 0
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#line vty 0 15
S1(config-line)#password cisco
S1(config-line)#login
S1(config-line)#end
%SYS-5-CONFIG_I: Configured from console by console
S1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

2. Настроить Ethernet интерфейсы персональных компьютеров
Настроить  сетевые интерфейсы PC1, PC2, PC3, PC4, PC5 и PC6 в соответствии с планом адресации.  Используя команду ping, убедится в наличии связи между PC1 и PC4,  PC2 и PC5, а также между PC3 и PC6. 

3. Настроить VTP на свитчах
·         Настроить operating mode, domain name, и VTP password на всех коммутаторах

S1(config)#vtp mode server
Device mode already VTP SERVER.
S1(config)#vtp domain StpLab
Changing VTP domain name from NULL to StpLab
S1(config)#vtp password cisco
Setting device VLAN database password to cisco
S1(config)#end

S2(config)#vtp mode client
Setting device to VTP CLIENT mode
S2(config)#vtp domain StpLab
Changing VTP domain name from NULL to StpLab
S2(config)#vtp password cisco
Setting device VLAN database password to cisco
S2(config)#end

S3(config)# vtp mode client
Setting device to VTP CLIENT mode
S3(config)#vtp domain StpLab
Changing VTP domain name from NULL to StpLab
S3(config)#vtp password cisco
Setting device VLAN database password to cisco
S3(config)#end

·         Сконфигурировать native VLAN для trunk портов на всех коммутаторах
Для упрощения процесса необходимо использовать команду interface range

S1(config)#interface range fa0/1-5
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#switchport trunk native vlan 99
S1(config-if-range)#no shutdown
S1(config-if-range)#end

S2(config)# interface range fa0/1-5
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#switchport trunk native vlan 99
S2(config-if-range)#no shutdown
S2(config-if-range)#end

S3(config)# interface range fa0/1-5
S3(config-if-range)#switchport mode trunk
S3(config-if-range)#switchport trunk native vlan 99
S3(config-if-range)#no shutdown
S3(config-if-range)#end

·         Настроить  VLAN-ы  на  VTP сервере

VLAN 99 (management)
VLAN 10 (Red)
VLAN 20 (Green)
VLAN 30 (Blue)


S1(config)#vlan 99
S1(config-vlan)#name management
S1(config-vlan)#exit
S1(config)#vlan 10
S1(config-vlan)#name Red
S1(config-vlan)#exit
S1(config)#vlan 20
S1(config-vlan)#name Green
S1(config-vlan)#exit
S1(config)#vlan 30
S1(config-vlan)#name Blue
S1(config-vlan)#exit

Проверить выполненные действия командой show vlan brief

·         Проверить  распространение созданных VLAN-ов на  S2 и S3
Используя команду show vlan brief  на S2 и S3, убедится в том, что созданные на VTP-сервере VLAN-ы были распределены на все коммутаторы.

S2#show vlan brief
VLAN Name                              Status    Ports
---- -------------------------------- --------- -----------------------------
1   default                           active    Fa0/1, Fa0/2, Fa0/4, Fa0/5
 Fa0/6, Fa0/7, Fa0/8, Fa0/9
 Fa0/10, Fa0/11, Fa0/12,Fa0/13
 Fa0/14, Fa0/15, Fa0/16,Fa0/17
 Fa0/18, Fa0/19, Fa0/20,Fa0/21
 Fa0/22, Fa0/23, Fa0/24, Gi0/1
 Gi0/2
10   Red                         active
20   Green                             active
30   Blue                              active
99   management                        active

S3#show vlan brief
VLAN Name                              Status    Ports
---- -------------------------------- --------- -----------------------------
1    default                          active    Fa0/1, Fa0/2, Fa0/4, Fa0/5
 Fa0/6, Fa0/7, Fa0/8, Fa0/9
 Fa0/10, Fa0/11, Fa0/12,Fa0/13
 Fa0/14, Fa0/15, Fa0/16,Fa0/17
 Fa0/18, Fa0/19, Fa0/20,Fa0/21
 Fa0/22, Fa0/23, Fa0/24, Gi0/1
 Gi0/2
1002 fddi-default                      act/unsup
1003 token-ring-default                act/unsup
1004 fddinet-default                   act/unsup
1005 trnet-default                     act/unsup

·         Настроить IP-адреса для интерфейсов управления на S1, S2 и S3 .

S1(config)#interface vlan 99
S1(config-if)#ip address 192.168.99.11 255.255.255.0
S1(config-if)#no shutdown

S2(config)#interface vlan 99
S2(config-if)#ip address 192.168.99.12 255.255.255.0
S2(config-if)#no shutdown

S3(config)#interface vlan 99
S3(config-if)#ip address 192.168.99.13 255.255.255.0
S3(config-if)#no shutdown

·         Назначить порты соотвествующим VLAN согласно таблицы назначения портов.

S1(config)#interface range fa0/6-10
S1(config-if-range)#switchport access vlan 30
S1(config-if-range)#interface range fa0/11-17
S1(config-if-range)#switchport access vlan 10
S1(config-if-range)#interface range fa0/18-24
S1(config-if-range)#switchport access vlan 20
S1(config-if-range)#end
S1#copy running-config startup-config
Destination filename [startup-config]? [enter]
Building configuration...
[OK]

S3(config)#interface range fa0/6-10
S3(config-if-range)#switchport access vlan 30
S3(config-if-range)#interface range fa0/11-17
S3(config-if-range)#switchport access vlan 10
S3(config-if-range)#interface range fa0/18-24
S3(config-if-range)#switchport access vlan 20
S3(config-if-range)#end
S3#copy running-config startup-config
Destination filename [startup-config]? [enter]
Building configuration...
[OK]

4. Изучить конфигурацию Spanning Tree
·         При помощи команды  show spanning-tree проверить текущую конфигурацию STP

S1#show spanning-tree
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     0005.5EB4.1254
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0005.5EB4.1254
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/2            Desg FWD 19        128.2    P2p
Fa0/3            Desg FWD 19        128.3    P2p
Fa0/4            Desg FWD 19        128.4    P2p
Fa0/1            Desg FWD 19        128.1    P2p
Fa0/6            Desg FWD 19        128.6    P2p
Fa0/11           Desg FWD 19        128.11   P2p
Fa0/18           Desg FWD 19        128.18   P2p

VLAN0010
  Spanning tree enabled protocol ieee
  Root ID    Priority    32778
             Address     0005.5EB4.1254
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32778  (priority 32768 sys-id-ext 10)
             Address     0005.5EB4.1254
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/2            Desg FWD 19        128.2    P2p
Fa0/3            Desg FWD 19        128.3    P2p
Fa0/4            Desg FWD 19        128.4    P2p
Fa0/1            Desg FWD 19        128.1    P2p

VLAN0020
  Spanning tree enabled protocol ieee
  Root ID    Priority    32788
             Address     0005.5EB4.1254
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32788  (priority 32768 sys-id-ext 20)
             Address     0005.5EB4.1254
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/2            Desg FWD 19        128.2    P2p
Fa0/3            Desg FWD 19        128.3    P2p
Fa0/4            Desg FWD 19        128.4    P2p
Fa0/1            Desg FWD 19        128.1    P2p

VLAN0030
  Spanning tree enabled protocol ieee
  Root ID    Priority    32798
             Address     0005.5EB4.1254
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32798  (priority 32768 sys-id-ext 30)
             Address     0005.5EB4.1254
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/2            Desg FWD 19        128.2    P2p
Fa0/3            Desg FWD 19        128.3    P2p
Fa0/4            Desg FWD 19        128.4    P2p
Fa0/1            Desg FWD 19        128.1    P2p

VLAN0099
  Spanning tree enabled protocol ieee
  Root ID    Priority    32867
             Address     0005.5EB4.1254
             This bridge is the root
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32867  (priority 32768 sys-id-ext 99)
             Address     0005.5EB4.1254
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/2            Desg FWD 19        128.2    P2p
Fa0/3            Desg FWD 19        128.3    P2p
Fa0/4            Desg FWD 19        128.4    P2p
Fa0/1            Desg FWD 19        128.1    P2p


S2#show spanning-tree
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     0005.5EB4.1254
             Cost        19
             Port        3(FastEthernet0/3)
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     0090.2B49.7891
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20
Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Altn BLK 19        128.1    P2p
Fa0/2            Altn BLK 19        128.2    P2p
Fa0/3            Root FWD 19        128.3    P2p
Fa0/4            Altn BLK 19        128.4    P2p

------------------------------------пропущено--------------------------------

S3#show spanning-tree
VLAN0001
  Spanning tree enabled protocol ieee
  Root ID    Priority    32769
             Address     0005.5EB4.1254
             Cost        19
             Port        1(FastEthernet0/1)
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec

  Bridge ID  Priority    32769  (priority 32768 sys-id-ext 1)
             Address     000C.857B.E573
             Hello Time  2 sec  Max Age 20 sec  Forward Delay 15 sec
             Aging Time  20

Interface        Role Sts Cost      Prio.Nbr Type
---------------- ---- --- --------- -------- --------------------------------
Fa0/1            Root FWD 19        128.1    P2p
Fa0/2            Altn BLK 19        128.2    P2p
Fa0/3            Desg FWD 19        128.3    P2p
Fa0/4            Desg FWD 19        128.4    P2p
Fa0/6            Desg FWD 19        128.6    P2p
Fa0/11           Desg FWD 19        128.11   P2p
Fa0/18           Desg FWD 19        128.18   P2p

------------------------------------пропущено--------------------------------
5. Изучить процесс конвергенции STP
·         Из командной строки PC5 выполнить команду ping  с параметром –t для PC2
·         На коммутаторе S3 для порта с ролью Root (в данном проекте Fa0/1) выполнить команду shutdown.

S3(config)#interface F0/1
S3(config-if)#shutdown

·         Отметить примерное время схождения сети,  исходя из вывода команды ping.



·         Вернуть предыдущее состояние порта командой no shutdown.

S3(config-if)#no shutdown

6. Настроить на коммутаторах Rapid Spanning Tree Protocol
·         На коммутаторах S1,S2 и S3 включить для spanning-tree режим rapid-pvst

S1(config)#spanning-tree mode rapid-pvst

S2(config)#spanning-tree mode rapid-pvst

S3(config)#spanning-tree mode rapid-pvst

·         На коммутаторах S1,S2 и S3 настроить порты, находящиеся в режиме access,  для использования в роли RSTP Edge –портов

S1(config)#interface range fa0/6-10
S1(config-if-range)#spanning-tree portfast
S1(config-if-range)#interface range fa0/11-17
S1(config-if-range)#spanning-tree portfast
S1(config-if-range)#interface range fa0/18-24
S1(config-if-range)#spanning-tree portfast

S3(config)#interface range fa0/6-10
S3(config-if-range)#spanning-tree portfast
S3(config-if-range)#interface range fa0/11-17
S3(config-if-range)#spanning-tree portfast
S3(config-if-range)#interface range fa0/18-24
S3(config-if-range)#spanning-tree portfast

7. Изучить процесс конвергенции RSTP
·         Повторить пункт 5.

1 комментарий:

Анонимный комментирует...

Доброго времени суток!
В пункте 1 в примере настройки пропущена
настроика message-of-the-day banner.

Отправить комментарий