8 мая 2013 г.

Лабораторная работа CCNA #FastPass - DHCP and NAT Lab 1 Basics

Лабораторная работа CCNA #FastPass - DHCP and NAT Lab 1 Basics
Лабораторная работа CCNA по теме DHCP and NAT.  Данная лабораторная работа может быть выполнена на реальном оборудовании  или в Cisco Packet Tracer.  Все необходимые действия указаны по порядку их выполнения. Для начала выполнения лабораторной работы необходимо соединить физическую сеть в соответствии со схемой сети или построить соответствующий проект в Cisco Packet Tracer.  Сразу после схемы сети в таблице указана схема адресация, которую нужно применять только тогда, когда это будет явно указано в тексте лабораторной работы. 

Используемая топология

Лабораторная работа CCNA #FastPass - DHCP and NAT Lab 1 Basics
План адресации
Device
Interface
IP Address
Subnet Mask
Default Gateway
R1
S0/0
192.168.0.1
255.255.255.252
N/A
Fa0/0
192.168.1.1
255.255.255.0
N/A
Fa0/1
192.168.2.1
255.255.255.0
N/A
R2
S0/0
192.168.0.2
255.255.255.252
N/A
S0/1
203.0.113.225
255.255.255.252
N/A
Fa0/0
192.168.3.1
255.255.255.0
N/A
ISP
S0/1
203.0.113.226
255.255.255.252
N/A
PC1
NIC
192.168.1.11
255.255.255.0
192.168.1.1
PC2
NIC
192.168.2.11
255.255.255.0
192.168.2.1
Server
NIC
192.168.3.254
255.255.255.0
192.168.3.1



1. Базовая конфигурация оборудования
·         Настроить hostname на маршрутизаторах.
·         Отключить DNS lookup.
·         Установить пароль для  EXEC mode
·         Настроить message-of-the-day banner.
·         Установить пароль для console

2. Настроить адресацию оборудования согласно плана
·         Настроить интерфейсы на R1, R2 и ISP согласно плана адресации.
·         Проверить выполненные настройки командой show ip interface brief
·         Настроить интерфейс Server в соответствии с таблицей
·         Проверить выполненные настройки командой ping.
·         Настроить интерфейсы PC1 и PC2 на автоматическое конфигурирование.
·         Сконфигурировать протокол динамической маршрутизации OSPF на R1 и R2. Не включать сеть 203.0.113.224/27 в анонсы протокола OSPF.
·         Добавить на R2 маршрут по умолчанию и настроить перераспределение в среду OSPF
·         Проверить правильность выполненных настроек командой show ip route.

3. Настроить DHCP Server на R2
·         Настроить  диапазоны исключаемых адресов

R2(config)#ip dhcp excluded-address 192.168.1.1 192.168.1.10
R2(config)#ip dhcp excluded-address 192.168.2.1 192.168.2.10

·         Создать пул адресов для сети 192.168.1.0/24, подключенной к R1. Шлюз по умолчанию 192.168.1.1, DNS сервер 192.168.3.254

R2(config)#ip dhcp pool R1-pool-1.0
R2(dhcp-config)#network 192.168.1.0 255.255.255.0
R2(dhcp-config)#dns-server 192.168.3.254
R2(dhcp-config)#default-router 192.168.1.1

·         Создать пул адресов для сети 192.168.2.0/24, подключенной к R1. Шлюз по умолчанию 192.168.2.1, DNS сервер 192.168.3.254

R2(config)#ip dhcp pool R1-pool-2.0
R2(dhcp-config)#network 192.168.2.0 255.255.255.0
R2(dhcp-config)#dns-server 192.168.3.254
R2(dhcp-config)#default-router 192.168.2.1

4. Настроить DHCP Relay на R1
·         Индивидуально для каждого интерфейса  необходимо указать параметр ip helper-address

R1(config)#interface fa0/0
R1(config-if)#ip helper-address 192.168.0.2
R1(config)#interface fa0/1
R1(config-if)#ip helper-address 192.168.0.2

·         Проверить конфигурацию и работу сервиса  DHCP

R2#show ip dhcp binding
IP address       Client-ID/              Lease expiration        Type
                 Hardware address
192.168.1.11     0060.4745.5DC3          Sep 14 2011 07:33 PM    Automatic
192.168.2.11     0060.5C56.2EB1          Sep 14 2011 07:33 PM    Automatic




R6#show ip dhcp pool

Pool R1-pool-1.0 :
 Utilization mark (high/low)    : 100 / 0
 Subnet size (first/next)       : 0 / 0
 Total addresses                : 254
 Leased addresses               : 1
 Pending event                  : none
 1 subnet is currently in the pool :
 Current index        IP address range                    Leased addresses
 192.168.1.12          192.168.1.1      - 192.168.1.254     1

Pool R1-pool-2.0 :
 Utilization mark (high/low)    : 100 / 0
 Subnet size (first/next)       : 0 / 0
 Total addresses                : 254
 Leased addresses               : 1
 Pending event                  : none
 1 subnet is currently in the pool :
 Current index        IP address range                    Leased addresses
 192.168.2.12         192.168.2.1      - 192.168.2.254     1

5. Настроить Static NAT
·         Настроить  статическую трансляцию для Server, подключенного к интерфейсу R2.

R2(config)#ip nat inside source static 192.168.3.254 203.0.113.254

·          Указать inside и outside интерфейсы

R2(config)#interface serial 0/1
R2(config-if)#ip nat outside
R2(config-if)#interface fa0/0
R2(config-if)#ip nat inside

·         Проверить выполненные настройки командой ping и show ip nat translations

ISP#ping 203.0.113.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 203.0.113.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 7/10/14 ms

R2#show ip nat translations
Pro  Inside global     Inside local       Outside local      Outside global
icmp 203.0.113.254:53192.168.3.254:53   203.0.113.226:53 203.0.113.226:53
icmp 203.0.113.254:54192.168.3.254:54   203.0.113.226:54 203.0.113.226:54
icmp 203.0.113.254:55192.168.3.254:55   203.0.113.226:55 203.0.113.226:55
icmp 203.0.113.254:56192.168.3.254:56   203.0.113.226:56 203.0.113.226:56
icmp 203.0.113.254:57192.168.3.254:57   203.0.113.226:57 203.0.113.226:57
---  203.0.113.254   192.168.3.254      ---                ---

6. Настроить Dynamic NAT
·         Создать пул IP-адресов для динамической трансляции

R2(config)#ip nat pool Pool4Nat 203.0.113.241 203.0.113.246 netmask 255.255.255.248

·         Создать extended ACL определяющий адреса для динамической трансляции

R2(config)#access-list 100 permit ip 192.168.1.0 0.0.0.255 any
R2(config)#access-list 100 permit ip 192.168.2.0 0.0.0.255 any

·         Настроить  динамическую трансляцию для локальных IP-адресов, определяемых ACL 100,в реальные IP-адреса из  пула Pool4Nat.

R2(config)#ip nat inside source list 100 pool Pool4Nat

·         Указать inside интерфейс для данного вида трансляции (outside интерфейс уже был сконфигурирован в предыдущем примере )

R2(config)#interface serial 0/0
R2(config-if)#ip nat inside

·         Проверить выполненные настройки командой ping и show ip nat translations

R2#show ip nat translations
Pro  Inside global     Inside local       Outside local      Outside global
icmp 203.0.113.241:53192.168.1.11:53     203.0.113.226:53 203.0.113.226:53
---  203.0.113.241   192.168.1.11        ---                ---
---  203.0.113.254   192.168.3.254       ---                ---

R2#show ip nat statistics
Total active translations: 2 (1 static, 1 dynamic; 0 extended)
Outside interfaces:
Serial0/1
Inside interfaces:
Serial0/0
Hits: 23 Misses: 3
CEF Translated packets: 18, CEF Punted packets: 0
Expired translations: 3
Dynamic mappings:
-- Inside Source
[Id: 1] access-list 100 pool Pool4Nat refcount 1
pool Pool4Nat: netmask 255.255.255.248
start 203.0.113.241 end 203.0.113.246
type generic, total addresses 6, allocated 1 (16%), misses 0
Queued Packets: 0

7. Настроить PAT (NAT Overload)
·         Удалить предыдущую конфигурацию NAT.

R2(config)#no ip nat inside source list 100 pool Pool4Nat
R2(config)#no ip nat pool Pool4Nat 203.0.113.241 203.0.113.246 netmask 255.255.255.248

·         Настроить PAT на R2, используя IP- адресс интерфейса Serial 0/1

R2(config)#ip nat inside source list NAT interface S0/1 overload

·         Проверить выполненные настройки командой ping и show ip nat translations

R2#show ip nat translations
Pro  Inside global         Inside local       Outside local          Outside global
icmp 203.0.113.241:6    192.168.1.11:6    203.0.113.226:6 203.0.113.226:6
---  203.0.113.254   192.168.20.254        ---                ---

R2#show ip nat statistics
Total active translations: 2 (1 static, 1 dynamic; 1 extended)
Outside interfaces:
Serial0/1
Inside interfaces:

Комментариев нет:

Отправить комментарий