7 мая 2013 г.

Лабораторная работа CCNA #FastPass - EIGRP Lab 1 Basics

Лабораторная работа CCNA #FastPass -  EIGRP Lab 1 Basics
Лабораторная работа CCNA по теме EIGRP.  Данная лабораторная работа может быть выполнена на реальном оборудовании  или в Cisco Packet Tracer.  Все необходимые действия указаны по порядку их выполнения. Для начала выполнения лабораторной работы необходимо соединить физическую сеть в соответствии со схемой сети или построить соответствующий проект в Cisco Packet Tracer.  Сразу после схемы сети в таблице указана схема адресация, которую нужно применять только тогда, когда это будет явно указано в тексте лабораторной работы. 

Используемая топология

Лабораторная работа CCNA #FastPass -  EIGRP Lab 1 Basics


План адресации
Device
Interface
IP Address
Subnet Mask
Default Gateway
R1
Fa0/0
172.17.1.1
255.255.255.0
N/A
S0/0
172.17.3.1
255.255.255.252
N/A
S0/1
192.168.1.5
255.255.255.252
N/A
R2
Fa0/0
172.17.2.1
255.255.255.0
N/A
S0/0
172.17.3.2
255.255.255.252
N/A
S0/1
192.168.1.9
255.255.255.252
N/A
Lo1
203.0.113.1
255.255.255.252
N/A
R3
Fa0/0
192.168.10.1
255.255.255.0
N/A
S0/0
192.168.1.6
255.255.255.252
N/A
S0/1
192.168.1.10
255.255.255.252
N/A
PC1
NIC
172.17.1.10
255.255.255.0
172.17.1.1
PC2
NIC
172.17.2.10
255.255.255.0
172.17.2.1
PC3
NIC
192.168.10.10
255.255.255.0
192.168.10.1




1. Базовая конфигурация оборудования
·         Настроить hostname на маршрутизаторах.
·         Отключить DNS lookup.
·         Установить пароль для  EXEC mode
·         Настроить message-of-the-day banner.
·         Установить пароль для console

2. Настроить адресацию оборудования согласно плана
·         Настроить интерфейсы на R1, R2 и R3 согласно плана адресации.
·         Проверить выполненные настройки командой show ip interface brief

3. Настроить протокол динамической маршрутизации EIGRP на маршрутизаторе R1
·         Активировать  EIGRP на R1 используя Process ID 1

R1(config)#router eigrp 1
R1(config-router)#

·         Используя команду network, сконфигурировать маршрутизатор R1 для анонсирования сети  172.17.0.0

R1(config-router)#network 172.17.0.0
R1(config-router)#

·         Настроить анонсирование сети  192.168.1.4/30

R1(config-router)# network 192.168.1.4 0.0.0.3
R1(config-router)#

4. Настроить протокол динамической маршрутизации EIGRP на маршрутизаторе R2

R2(config)#router eigrp 1
R2(config-router)#
R2(config-router)#network 172.17.0.0
R2(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 172.17.3.1 (Serial0/0) is up:
new adjacency
R2(config-router)#network 192.168.1.8 0.0.0.3

5. Настроить протокол динамической маршрутизации EIGRP на маршрутизаторе R3

R3(config)#router eigrp 1
R3(config-router)#network 192.168.1.0
R3(config-router)#network 192.168.1.4 0.0.0.3
R3(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.1.5 (Serial0/0) is up:
new adjacency
R3(config-router)#network 192.168.1.8 0.0.0.3
R3(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 192.168.1.9 (Serial0/1) is up:
new adjacency    

6. Проверить правильность выполненных настроек
·         Используя команды show ip eigrp neighbors вывести таблицу соседних EIGRP-маршрутизаторов

R1#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address         Interface      Hold  Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   172.17.3.2      Se0/0          11    00:08:43   40     1000  0   8
1   192.168.1.6     Se0/1          11    00:02:30   40     1000  0   4

R2#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address         Interface      Hold  Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   172.17.3.1      Se0/0          12    00:11:45  40     1000  0   6
1   192.168.1.10    Se0/1          13    00:05:26  40     1000  0   6

R3#show ip eigrp neighbors
IP-EIGRP neighbors for process 1
H   Address         Interface      Hold  Uptime    SRTT   RTO   Q   Seq
                                   (sec)          (ms)        Cnt  Num
0   192.168.1.5     Se0/0          13    00:07:54  40     1000  0   10
1   192.168.1.9     Se0/1          13    00:07:48  40     1000  0   12

·         Вывести детальную информацию по используемому протоколу динамической маршрутизации командой show ip protocols

R1#show ip protocols

Routing Protocol is "eigrp  1 "
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates 
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
Redistributing: eigrp 1
  Automatic network summarization is in effect 
  Automatic address summarization:
    192.168.1.0/24 for FastEthernet0/0, Serial0/0
      Summarizing with metric 20512000
    172.17.0.0/16 for Serial0/1
      Summarizing with metric 28160
  Maximum path: 4
  Routing for Networks: 
     172.17.0.0
     192.168.1.4/30
  Routing Information Sources: 
    Gateway         Distance      Last Update
    172.17.3.2      90            1495932   
    192.168.1.6     90            1869249   
  Distance: internal 90 external 170

R2#show ip protocols

Routing Protocol is "eigrp  1 "
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates 
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
Redistributing: eigrp 1
  Automatic network summarization is in effect 
  Automatic address summarization:
    192.168.1.0/24 for FastEthernet0/0, Serial0/0
      Summarizing with metric 20512000
    172.17.0.0/16 for Serial0/1
      Summarizing with metric 28160
  Maximum path: 4
  Routing for Networks: 
     172.17.0.0
     192.168.1.8/30
  Routing Information Sources: 
    Gateway         Distance      Last Update
    172.17.3.1      90            1481780   
    192.168.1.10    90            1860679   
  Distance: internal 90 external 170

R3#show ip protocols

Routing Protocol is "eigrp  1 "
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates 
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
Redistributing: eigrp 1
  Automatic network summarization is in effect 
  Automatic address summarization:
  Maximum path: 4
  Routing for Networks: 
     192.168.10.0
     192.168.1.4/30
     192.168.1.8/30
  Routing Information Sources: 
    Gateway         Distance      Last Update
    192.168.1.5     90            1839702   
    192.168.1.9     90            1845281   
  Distance: internal 90 external 170

7. Анализ EIGRP маршрутов
·         Просмотр таблицы маршрутизации

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     172.17.0.0/16 is variably subnetted, 4 subnets, 3 masks
D       172.17.0.0/16 is a summary, 00:24:13, Null0
C       172.17.1.0/24 is directly connected, FastEthernet0/0
D       172.17.2.0/24 [90/20514560] via 172.17.3.2, 00:26:40, Serial0/0
C       172.17.3.0/30 is directly connected, Serial0/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
D       192.168.1.0/24 is a summary, 00:24:13, Null0
C       192.168.1.4/30 is directly connected, Serial0/1
D       192.168.1.8/30 [90/21024000] via 192.168.1.6, 00:20:21, Serial0/1
D    192.168.10.0/24 [90/20514560] via 192.168.1.6, 00:00:28, Serial0/1

R2#show ip route

-----------------------------пропущено----------------------------
     172.17.0.0/16 is variably subnetted, 4 subnets, 3 masks
D       172.17.0.0/16 is a summary, 00:30:13, Null0
D       172.17.1.0/24 [90/20514560] via 172.17.3.1, 00:35:13, Serial0/0
C       172.17.2.0/24 is directly connected, FastEthernet0/0
C       172.17.3.0/30 is directly connected, Serial0/0
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
D       192.168.1.0/24 is a summary, 00:30:13, Null0
D       192.168.1.4/30 [90/21024000] via 192.168.1.10, 00:28:54, Serial0/1
C       192.168.1.8/30 is directly connected, Serial0/1
D    192.168.10.0/24 [90/20514560] via 192.168.1.10, 00:01:47, Serial0/1

R3#show ip route

-----------------------------пропущено----------------------------
D    172.17.0.0/16 [90/20514560] via 192.168.1.5, 00:31:34, Serial0/0
                   [90/20514560] via 192.168.1.9, 00:31:29, Serial0/1
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
D       192.168.1.0/24 is a summary, 00:04:21, Null0
C       192.168.1.4/30 is directly connected, Serial0/0
C       192.168.1.8/30 is directly connected, Serial0/1
C    192.168.10.0/24 is directly connected, FastEthernet0/0

8. Настройка EIGRP-Metrics
·         Получение значений составляющих EIGRP-Metric для интерфейса Serial 0/0 маршрутизатора R1 из вывода команды show interfaces Serial0/0.

R1#show interfaces Serial0/0
Serial0/0 is up, line protocol is up (connected)
Hardware is HD64570
Internet address is 192.168.1.1/30
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation HDLC, loopback not set, keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
-----------------------------пропущено----------------------------

·         Установка значений bandwidth для Serial-интерфейсов маршрутизаторов R1, R2 и R3


R1(config)#interface Serial0/0
R1(config-if)#bandwidth 64

R2(config)#interface Serial0/0
R2(config-if)#bandwidth 64
R2(config)#interface serial0/1
R2(config-if)#bandwidth 256

R3(config)#interface serial0/1
R3(config-if)#bandwidth 256

·         Проверить выполненные изменения параметра bandwidth

R1#show interfaces Serial0/0
Serial0/0 is up, line protocol is up (connected)
Hardware is HD64570
Internet address is 172.17.3.1/30
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation HDLC, loopback not set, keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
-----------------------------пропущено----------------------------


R2#show interfaces Serial0/0
Serial0/0 is up, line protocol is up (connected)
Hardware is HD64570
Internet address is 172.17.3.2/30
MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation HDLC, loopback not set, keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
-----------------------------пропущено----------------------------


R3#show interfaces Serial0/1
Serial0/0 is up, line protocol is up (connected)
Hardware is HD64570
Internet address is 192.168.1.10/30
MTU 1500 bytes, BW 256 Kbit, DLY 20000 usec, rely 255/255, load 1/255
Encapsulation HDLC, loopback not set, keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
-----------------------------пропущено----------------------------

9. Отключение автоматического суммирования маршрутов EIGRP
·         Получение информации о суммарных маршрутах в таблице маршрутизации R3

R3#show ip route
-----------------------------пропущено----------------------------
D    172.17.0.0/16 [90/10514432] via 192.168.1.9, 00:00:21, Serial0/1
     192.168.1.0/24 is variably subnetted, 3 subnets, 2 masks
D       192.168.1.0/24 is a summary, 00:00:22, Null0
C       192.168.1.4/30 is directly connected, Serial0/0
C       192.168.1.8/30 is directly connected, Serial0/1
C    192.168.10.0/24 is directly connected, FastEthernet0/0

R3#show ip eigrp topology
-----------------------------пропущено----------------------------
P 192.168.10.0/24, 1 successors, FD is 28160
         via Connected, FastEthernet0/0
P 192.168.1.8/30, 1 successors, FD is 10511872
         via Connected, Serial0/1
P 192.168.1.0/24, 1 successors, FD is 10511872
         via Summary (10511872/0), Null0
P 192.168.1.4/30, 1 successors, FD is 20512000
         via Connected, Serial0/0
P 172.17.0.0/16, 1 successors, FD is 10514432
         via 192.168.1.9 (10514432/28160), Serial0/1
         via 192.168.1.5 (20514560/28160), Serial0/0

R1 получает информацию о суммарном маршруте для сети 172.17.0.0/16 от соседних EIGRP маршрутизаторов

·         Отключить автоматическое суммирование маршрутов

R1(config)#router eigrp 1
R1(config-router)#no auto-summary

R2(config)#router eigrp 1
R2(config-router)#no auto-summary

R3(config)#router eigrp 1
R3(config-router)#no auto-summary
·         Проверить результат изменения конфигурации в таблице маршрутизации R3

R3#show ip route
-----------------------------пропущено----------------------------
     172.17.0.0/16 is variably subnetted, 3 subnets, 2 masks
D       172.17.1.0/24 [90/20514560] via 192.168.1.5, 00:40:55, Serial0/0
D       172.17.2.0/24 [90/10514432] via 192.168.1.9, 00:40:55, Serial0/1
D       172.17.3.0/30 [90/41024000] via 192.168.1.9, 00:40:55, Serial0/1
                      [90/41024000] via 192.168.1.5, 00:40:55, Serial0/0
     192.168.1.0/30 is subnetted, 2 subnets
C       192.168.1.4 is directly connected, Serial0/0
C       192.168.1.8 is directly connected, Serial0/1
C    192.168.10.0/24 is directly connected, FastEthernet0/0

10. Настроить суммирование маршрутов для протокола EIGRP
·         Добавить Loopback интерфейс с IP-адресом 192.168.11.1/24 на маршрутизаторе R3

R3(config)#interface Loopback0
R3(config-if)#ip address 192.168.11.1 255.255.255.0
R3(config-if)#exit

·         Добавить сеть 192.168.11.0/24 в конфигурацию EIGRP на R3

R3(config)#router eigrp 1
R3(config-router)#network 192.168.11.0 0.0.0.255

·         Проверить наличие сети 192.168.11.0/24 в таблице маршрутизации на R1

-----------------------------пропущено----------------------------
     172.17.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.17.1.0/24 is directly connected, FastEthernet0/0
D       172.17.2.0/24 [90/21026560] via 192.168.1.6, 01:04:26, Serial0/1
C       172.17.3.0/30 is directly connected, Serial0/0
     192.168.1.0/30 is subnetted, 2 subnets
C       192.168.1.4 is directly connected, Serial0/1
D       192.168.1.8 [90/21024000] via 192.168.1.6, 01:04:26, Serial0/1
D    192.168.10.0/24 [90/20514560] via 192.168.1.6, 01:04:26, Serial0/1
D    192.168.11.0/24 [90/20640000] via 192.168.1.6, 00:01:33, Serial0/1

·         Настроить анонсирование суммарного маршрута для сетей 192.168.10.0/24 и 192.168.11.0/24 на R3

R3(config)#int Serial0/0
R3(config-if)#ip summary-address eigrp 1 192.168.10.0 255.255.254.0
R3(config)#int Serial0/1
R3(config-if)#ip summary-address eigrp 1 192.168.10.0 255.255.254.0

·         Проверить наличие суммарного маршрута для сетей 192.168.10.0/24 и 192.168.11.0/24 на R1

R1#show ip route

-----------------------------пропущено----------------------------
     172.17.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.17.1.0/24 is directly connected, FastEthernet0/0
D       172.17.2.0/24 [90/21026560] via 192.168.1.6, 00:00:16, Serial0/1
C       172.17.3.0/30 is directly connected, Serial0/0
     192.168.1.0/30 is subnetted, 2 subnets
C       192.168.1.4 is directly connected, Serial0/1
D       192.168.1.8 [90/21024000] via 192.168.1.6, 00:00:17, Serial0/1
D    192.168.10.0/23 [90/20514560] via 192.168.1.6, 00:00:17, Serial0/1


11. Настройка перераспределения маршрута по умолчанию в среду EIGRP
·         Добавить Loopback-интерфейс и  маршрут по умолчанию, эмулирующий соединение с ISP

R2(config)#interface Loopback 0
R2(config-if)#ip address 203.0.113.1 255.255.255.252
R2(config-if)#exit
R2(config)#ip route 0.0.0.0 0.0.0.0 Loopback 0

·         Добавить маршрут по умолчанию в анонсы EIGRP на R2

R2(config)#router eigrp 1
R2(config-router)#redistribute static

·         Проверить таблицу маршрутизации R1

R1#show ip route

-----------------------------пропущено----------------------------
Gateway of last resort is 192.168.1.6 to network 0.0.0.0

     172.17.0.0/16 is variably subnetted, 3 subnets, 2 masks
C       172.17.1.0/24 is directly connected, FastEthernet0/0
D       172.17.2.0/24 [90/21026560] via 192.168.1.6, 00:24:00, Serial0/1
C       172.17.3.0/30 is directly connected, Serial0/0
     192.168.1.0/30 is subnetted, 2 subnets
C       192.168.1.4 is directly connected, Serial0/1
D       192.168.1.8 [90/21024000] via 192.168.1.6, 00:24:02, Serial0/1
D    192.168.10.0/23 [90/20514560] via 192.168.1.6, 00:24:02, Serial0/1
D*EX 0.0.0.0/0 [170/22304000] via 192.168.1.6, 00:00:23, Serial0/1

4 комментария:

Acid комментирует...

Почему нету файла для Cisco Packet Tracer'а?

Анонимный комментирует...

cisco packet tracer не позволяет задать такую адресацию на одном роутере
172.17.1.1 /24 overlaps with 172.17.3.1 /30
Сами то хоть лабу проверяли перед тем как постить?? только время убил зазря...

Dave комментирует...

Рад что вы цените потраченное мной время на создание данных публикаций. Пожалуйста. Рекомендую еще раз прочесть ваш коменарий, и, если ничего странного в нем не видете, возврщайтесь к теме IP subnetting.

Анонимный комментирует...

Нашел свою ошибку. Пардон. Надо быть внимательней :)

Отправить комментарий