6 мая 2013 г.

Лабораторная работа CCNA #FastPass - OSPF Lab 2 Advanced

Лабораторная работа CCNA #FastPass - OSPF Lab 2 Basics
Лабораторная работа CCNA по теме OSPF.  Данная лабораторная работа может быть выполнена на реальном оборудовании  или в Cisco Packet Tracer.  Все необходимые действия указаны по порядку их выполнения. Для начала выполнения лабораторной работы необходимо соединить физическую сеть в соответствии со схемой сети или построить соответствующий проект в Cisco Packet Tracer.  Сразу после схемы сети в таблице указана схема адресация, которую нужно применять только тогда, когда это будет явно указано в тексте лабораторной работы. 

Используемая топология
Лабораторная работа CCNA #FastPass - OSPF Lab 2 Basics

План адресации
Device
Interface
IP Address
Subnet Mask
Default Gateway
R1
Fa0/0
192.168.1.1
255.255.255.0
N/A
Fa0/1
192.168.0.1
255.255.255.0
N/A
Lo0
192.168.255.1
255.255.255.255
N/A
R2
Fa0/0
192.168.2.1
255.255.255.0
N/A
Fa0/1
192.168.0.2
255.255.255.0
N/A
Lo0
192.168.255.2
255.255.255.255
N/A
R3
Fa0/0
192.168.3.1
255.255.255.0
N/A
Fa0/1
192.168.0.3
255.255.255.0
N/A
Lo0
192.168.255.3
255.255.255.255
N/A
PC1
NIC
192.168.1.254
255.255.255.0
192.168.1.1
PC2
NIC
192.168.2.254
255.255.255.0
192.168.2.1
PC3
NIC
192.168.3.254
255.255.255.0
192.168.3.1




1. Базовая конфигурация оборудования
·         Настроить hostname на маршрутизаторах.
·         Отключить DNS lookup.
·         Установить пароль для  EXEC mode
·         Настроить message-of-the-day banner.
·         Установить пароль для console

2. Настроить адресацию оборудования согласно плана
·         Настроить интерфейсы на R1, R2 и R3 согласно плана адресации.
·         Проверить выполненные настройки командой show ip interface brief

3. Настроить протокол динамической маршрутизации OSPF на DR-маршрутизаторе
Маршрутизатор R3 имеет самый высокий Router ID. Необходимо в первую очередь сконфигурировать протокол OSPF на R3, для того чтобы этот маршрутизатор стал DR.
·         Активировать  OSPF и настроить анонсирование подключенных сетей на R3

R3(config)#router ospf 1
R3(config-router)#network 192.168.0.0 0.0.0.255 area 0
R3(config-router)#network 192.168.3.0 0.0.0.255 area 0
R3(config-router)#passive-interface FastEthernet 0/0

·         Используя команду show ip ospf interface, убедиться в правильности конфигурации OSPF

R3#show ip ospf interface
-----------------------------пропущено----------------------------
FastEthernet0/1 is up, line protocol is up
  Internet address is 192.168.0.3/24, Area 0
  Process ID 1, Router ID 192.168.255.3, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 192.168.255.3, Interface address 192.168.0.3
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:05
-----------------------------пропущено----------------------------

4. Настроить протокол динамической маршрутизации OSPF на BDR-маршрутизаторе
Настроить OSPF  на маршрутизатор R2, который имеет второй по величине Router ID.
·         Активировать  OSPF и настроить анонсирование подключенных сетей на R2

R2(config)#router ospf 1
R2(config-router)#network 192.168.0.0 0.0.0.255 area 0
R2(config-router)#network
01:05:24: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.3 on FastEthernet0/1 from LOADING to FULL, Loading Done
R2(config-router)#network 192.168.2.0 0.0.0.255 area 0
R2(config-router)#passive-interface FastEthernet0/0

·         Используя команду show ip ospf interface, убедиться в правильности конфигурации OSPF

R2#show ip ospf interface
-----------------------------пропущено----------------------------
FastEthernet0/1 is up, line protocol is up
  Internet address is 192.168.0.2/24, Area 0
  Process ID 1, Router ID 192.168.255.2, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 192.168.255.3, Interface address 192.168.0.3
  Backup Designated Router (ID) 192.168.255.2, Interface address 192.168.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
-----------------------------пропущено----------------------------


·         Используя команду show ip ospf neighbor, получить информацию о соседних OSPF-маршрутизаторах

R2#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.255.3     1   FULL/DR         00:00:37    192.168.0.3     FastEthernet0/1

5. Настроить протокол динамической маршрутизации OSPF на DRother-маршрутизаторе
Настроить OSPF  на маршрутизатор R1, который имеет самый меньший Router ID.

·         Активировать  OSPF и настроить анонсирование подключенных сетей на R1

R1(config)#router ospf 1
R1(config-router)#network 192.168.0.0 0.0.0.255 area 0
R1(config-router)#
01:20:31: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.2 on FastEthernet0/1 from LOADING to FULL, Loading Done
01:20:31: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.3 on FastEthernet0/1 from LOADING to FULL, Loading Done
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#passive-interface FastEthernet0/0

·         Используя команду show ip ospf interface, убедиться в правильности конфигурации OSPF

R1#show ip ospf interface
-----------------------------пропущено----------------------------
FastEthernet0/1 is up, line protocol is up
  Internet address is 192.168.0.1/24, Area 0
  Process ID 1, Router ID 192.168.255.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DROTHER, Priority 1
  Designated Router (ID) 192.168.255.3, Interface address 192.168.0.3
  Backup Designated Router (ID) 192.168.255.2, Interface address 192.168.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:01
-----------------------------пропущено----------------------------

·         Используя команду show ip ospf neighbor, получить информацию о соседних OSPF-маршрутизаторах

R1#show ip ospf neighbor

Neighbor ID     Pri   State           Dead Time   Address         Interface
192.168.255.3     1   FULL/DR         00:00:32    192.168.0.3     FastEthernet0/1
192.168.255.2     1   FULL/BDR        00:00:35    192.168.0.2     FastEthernet0/1

6. Установить OSPF Priority для изменения порядка DR/BDR/Drother
·         Установить приоритет 100 для интерфейса Fa0/1 R1

R1(config)#interface FastEthernet 0/1
R1(config-if)#ip ospf priority 100

·         Установить приоритет 10 для интерфейса Fa0/1 R2

R2(config)#interface FastEthernet 0/1
R2(config-if)#ip ospf priority 10

·         Установить приоритет 0 для интерфейса Fa0/1 R3

R3(config)#interface FastEthernet 0/1
R3(config-if)#ip ospf priority 0

7. Отключить и включить интерфейсы маршрутизаторов для инициирования выборов
·         Отключить интерфейс Fa0/1 на R1

R1(config-if)#shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
02:06:26: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.3 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
02:06:26: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.2 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached

·         Отключить интерфейс Fa0/1 на R2

R2(config-if)#shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
02:06:13: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.3 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
02:06:13: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.1 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
·         Отключить интерфейс Fa0/1 на R3

R3(config-if)#shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to administratively down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
02:06:47: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.2 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
02:06:47: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.1 on FastEthernet0/1 from FULL to DOWN, Neighbor Down: Interface down or detached

·         Включить интерфейс Fa0/1 на R1

R1(config-if)#shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
02:18:14: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.2 on FastEthernet0/1 from LOADING to FULL, Loading Done
02:18:26: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.3 on FastEthernet0/1 from LOADING to FULL, Loading Done

·         Включить интерфейс Fa0/1 на R2

R2(config-if)#shutdown

%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
02:18:12: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.1 on FastEthernet0/1 from LOADING to FULL, Loading Done
02:18:24: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.3 on FastEthernet0/1 from LOADING to FULL, Loading Done

·         Включить интерфейс Fa0/1 на R3

R3(config-if)#shutdown


%LINK-5-CHANGED: Interface FastEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
02:18:55: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.1 on FastEthernet0/1 from LOADING to FULL, Loading Done
02:18:55: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.255.2 on FastEthernet0/1 from LOADING to FULL, Loading Done

·         Используя команду show ip ospf interface , убедиться в изменении порядка DR/BDR/Drother

R1#show ip ospf interface
-----------------------------пропущено----------------------------
FastEthernet0/1 is up, line protocol is up
  Internet address is 192.168.0.1/24, Area 0
  Process ID 1, Router ID 192.168.255.1, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DR, Priority 100
  Designated Router (ID) 192.168.255.1, Interface address 192.168.0.1
  Backup Designated Router (ID) 192.168.255.2, Interface address 192.168.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:07
-----------------------------пропущено----------------------------

R2#show ip ospf interface
-----------------------------пропущено----------------------------
FastEthernet0/1 is up, line protocol is up
  Internet address is 192.168.0.2/24, Area 0
  Process ID 1, Router ID 192.168.255.2, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State BDR, Priority 10
  Designated Router (ID) 192.168.255.1, Interface address 192.168.0.1
  Backup Designated Router (ID) 192.168.255.2, Interface address 192.168.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:03
-----------------------------пропущено----------------------------

R3#show ip ospf interface
-----------------------------пропущено----------------------------
FastEthernet0/1 is up, line protocol is up
  Internet address is 192.168.0.3/24, Area 0
  Process ID 1, Router ID 192.168.255.3, Network Type BROADCAST, Cost: 1
  Transmit Delay is 1 sec, State DROTHER, Priority 0
  Designated Router (ID) 192.168.255.1, Interface address 192.168.0.1
  Backup Designated Router (ID) 192.168.255.2, Interface address 192.168.0.2
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    Hello due in 00:00:09
-----------------------------пропущено----------------------------

Комментариев нет:

Отправить комментарий