5 мая 2013 г.

Лабораторная работа CCNA #FastPass - OSPF Lab 1 Basics

Лабораторная работа CCNA #FastPass - OSPF Lab 1 Basics
Лабораторная работа CCNA по теме OSPF.  Данная лабораторная работа может быть выполнена на реальном оборудовании  или в Cisco Packet Tracer.  Все необходимые действия указаны по порядку их выполнения. Для начала выполнения лабораторной работы необходимо соединить физическую сеть в соответствии со схемой сети или построить соответствующий проект в Cisco Packet Tracer.  Сразу после схемы сети в таблице указана схема адресация, которую нужно применять только тогда, когда это будет явно указано в тексте лабораторной работы. 

Используемая топология
Лабораторная работа CCNA #FastPass - OSPF Lab 1 Basics

План адресации
Device
Interface
IP Address
Subnet Mask
Default Gateway
R1
Fa0/0
172.16.0.17
255.255.255.240
N/A
S0/0
192.168.0.1
255.255.255.252
N/A
S0/1
192.168.0.5
255.255.255.252
N/A
R2
Fa0/0
10.1.1.1
255.255.255.0
N/A
S0/0
192.168.0.2
255.255.255.252
N/A
S0/1
192.168.0.9
255.255.255.252
N/A
R3
Fa0/0
172.16.0.33
255.255.255.248
N/A
S0/0
192.168.0.6
255.255.255.252
N/A
S0/1
192.168.0.10
255.255.255.252
N/A
PC1
NIC
172.16.0.20
255.255.255.240
172.16.0.17
PC2
NIC
10.1.1.10
255.255.255.0
10.1.1.1
PC3
NIC
172.16.0.35
255.255.255.248
172.16.0.33




1. Базовая конфигурация оборудования
·         Настроить hostname на маршрутизаторах.
·         Отключить DNS lookup.
·         Установить пароль для  EXEC mode
·         Настроить message-of-the-day banner.
·         Установить пароль для console

2. Настроить адресацию оборудования согласно плана
·         Настроить интерфейсы на R1, R2 и R3 согласно плана адресации.
·         Проверить выполненные настройки командой show ip interface brief

3.      Настроить протокол динамической маршрутизации OSPF на маршрутизаторах R1, R2 и R3
·         Активировать  OSPF на R1

R1(config)#router ospf 1
R1(config-router)#

·         Используя команду network, сконфигурировать маршрутизатор R1 для анонсирования сетей  172.16.0.16/28192.168.0.0/30 и 192.168.0.4/30

R1(config-router)#network 172.16.0.16 0.0.0.15 area 0
R1(config-router)#

R1(config-router)# network 192.168.0.0 0.0.0.3 area 0
R1(config-router)#

R1(config-router)# network 192.168.0.4 0.0.0.3 area 0
R1(config-router)#

·         Активировать  OSPF на R2

R2(config)#router ospf 1
R2(config-router)#

·         Используя команду network, сконфигурировать маршрутизатор R2 для анонсирования сетей  10.1.1.0/24192.168.0.0/30 и 192.168.0.8/30

R2(config-router)#network 10.1.1.0 0.0.0.255 area 0
R2(config-router)#
R2(config-router)#network 192.168.0.0 0.0.0.3 area 0
R2(config-router)#
00:07:27: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.0.5 on Serial0/0
from EXCHANGE to FULL, Exchange Done
R2(config-router)#network 192.168.0.8 0.0.0.3 area 0

·         Активировать  OSPF на R3

R3(config)#router ospf 1
R3(config-router)#

·         Используя команду network, сконфигурировать маршрутизатор R3 для анонсирования сетей  172.16.0.32/28192.168.0.4/30 и 192.168.0.4/30

R3(config-router)#network 172.16.0.32 0.0.0.7 area 0
R3(config-router)#network 192.168.0.4 0.0.0.3 area 0
R3(config-router)#
00:17:46: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.0.5 on Serial0/0
from LOADING to FULL, Loading Done
R3(config-router)#network 192.168.0.8 0.0.0.3 area 0
R3(config-router)#
00:18:01: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.0.9 on Serial0/1
from EXCHANGE to FULL, Exchange Done
R3(config-router)#end
%SYS-5-CONFIG_I: Configured from console by console
R3#

4.       Настроить OSPF Router ID
·         Используя команды show ip protocols, show ip ospf, и show ip ospf interfaces проверить текущие значения OSPF Router ID для маршрутизаторов R1, R2 и R3

R3#show ip protocols
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 192.168.0.10
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
-----------------------------пропущено----------------------------

R3#show ip ospf
Routing Process "ospf 1" with ID 192.168.0.10
Supports only single TOS(TOS0) routes
Supports opaque LSA
SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
-----------------------------пропущено----------------------------

R3#show ip ospf interface
FastEthernet0/0 is up, line protocol is up
Internet address is 172.16.0.33/29, Area 0
Process ID 1, Router ID 192.168.0.10    , Network Type BROADCAST, Cost:1
Transmit Delay is 1 sec, State DR, Priority 1
Designated Router (ID) 192.168.0.10, Interface address 172.16.0.33
No backup designated router on this network
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:00
Index 1/1, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 0, Adjacent neighbor count is 0
Suppress hello for 0 neighbor(s)

·         Используя  loopback-интерфейсы изменить OSPF Router ID на маршрутизаторах R1, R2 и R3

R1(config)#interface loopback 0
R1(config-if)#ip address 10.1.1.1 255.255.255.255

R2(config)#interface loopback 0
R2(config-if)#ip address 10.2.2.2 255.255.255.255

R3(config)#interface loopback 0
R3(config-if)#ip address 10.3.3.3 255.255.255.255

·         Для того чтобы новые изменения вступили в силу необходимо сохранить текущие конфигурации и перезагрузить маршрутизаторы.

·         Используя команду show ip ospf neighbors проверить полученные значения OSPF Router ID для маршрутизаторов R1, R2 и R3


R1# show ip ospf neighbor

Neighbor ID     Pri    State      Dead Time    Address        Interface
10.3.3.3        1      FULL/-     00:00:36     192.168.0.6     Serial0/1
10.2.2.2        1      FULL/-     00:00:36     192.168.0.2     Serial0/0

R2# show ip ospf neighbor

Neighbor ID     Pri    State      Dead Time    Address        Interface
10.3.3.3        1      FULL/-     00:00:36     192.168.0.10    Serial0/1
10.1.1.1        1      FULL/-     00:00:36     192.168.0.1     Serial0/0

R3# show ip ospf neighbor

Neighbor ID     Pri    State      Dead Time    Address        Interface
10.2.2.2        1      FULL/-     00:00:36     192.168.0.9     Serial0/1
10.1.1.1        1      FULL/-     00:00:36     192.168.0.5     Serial0/0

·         Изменить OSPF Router ID  для R1  командой router-id

R1(config)#router ospf 1
R1(config-router)#router-id 10.4.4.4
Reload or use “clear ip ospf process” command, for this to take effect

·         Для того чтобы новые изменения вступили в силу необходимо выполнить команду clear ip ospf process

R1# clear ip ospf process
Reset ALL OSPF processes? [no]:yes
R1#

·         Используя команду show ip ospf neighbors проверить полученное значение OSPF Router ID для маршрутизатора R1

R2# show ip ospf neighbor

Neighbor ID     Pri    State      Dead Time    Address        Interface
10.3.3.3        1      FULL/-     00:00:36     192.168.0.10    Serial0/1
10.4.4.4        1      FULL/-     00:00:36     192.168.0.1     Serial0/0

5.     Диагностика работы протокола OSPF
·         Получение информации о соседних OSPF- маршрутизаторах из вывода команды show ip ospf neighbors.

R1# show ip ospf neighbor

Neighbor ID     Pri    State      Dead Time    Address        Interface
10.3.3.3        1      FULL/-     00:00:36     192.168.0.6     Serial0/1
10.2.2.2        1      FULL/-     00:00:36     192.168.0.2     Serial0/0


·          Получение детальной информации о работе OSPF из вывода команды show ip protocols.

R1#show ip protocols

Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 10.1.1.1
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
172.16.0.16 0.0.0.15 area 0
192.168.0.0 0.0.0.3 area 0
192.168.0.4 0.0.0.3 area 0
Routing Information Sources:
Gateway   Distance Last Update
10.2.2.2   110 00:11:43
10.3.3.3   110 00:11:43
Distance: (default is 110)

R1#

6.    Получение информации об OSPF-маршрутах из таблицы маршрутизации

R1#show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B -
BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS
inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is not set

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C     10.1.1.1/32 is directly connected, Loopback0
O     10.1.1.0/24 [110/65] via 192.168.0.2, 00:01:02, Serial0/0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C     172.16.0.16/28 is directly connected, FastEthernet0/0
O     172.16.0.32/29 [110/65] via 192.168.0.6, 00:01:12, Serial0/1
192.168.0.0/30 is subnetted, 3 subnets
C     192.168.0.0 is directly connected, Serial0/0
C     192.168.0.4 is directly connected, Serial0/1
O     192.168.0.8 [110/128] via 192.168.0.6, 00:01:12, Serial0/1
                  [110/128] via 192.168.0.2, 00:01:02, Serial0/0

7.       Настройка значения OSPF-Cost
·         Получение информации о текущем значении Cost из вывода команды show ip route.

R1#show ip route
-----------------------------пропущено----------------------------
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C     10.1.1.1/32 is directly connected, Loopback0
O     10.1.1.0/24 [110/65] via 192.168.0.2, 00:01:02, Serial0/0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
C     172.16.0.16/28 is directly connected, FastEthernet0/0
O     172.16.0.32/29 [110/65] via 192.168.0.6, 00:01:12, Serial0/1
192.168.0.0/30 is subnetted, 3 subnets
C     192.168.0.0 is directly connected, Serial0/0
C     192.168.0.4 is directly connected, Serial0/1
O     192.168.0.8 [110/128] via 192.168.0.6, 00:01:12, Serial0/1
                  [110/128] via 192.168.0.2, 00:01:02, Serial0/0


·         Получение значения bandwidth для интерфейса Serial 0/0 маршрутизатора R1 из вывода команды show interfaces Serial0/0.


R1#show interfaces Serial0/0
Serial0/0 is up, line protocol is up (connected)
Hardware is HD64570
Internet address is 192.168.0.1/30
MTU 1500 bytes, BW 1544 Kbit, DLY 20000 usec, rely 255/255, load
1/255
Encapsulation HDLC, loopback not set, keepalive set (10 sec)
Last input never, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0 (size/max/drops); Total output drops: 0
-----------------------------пропущено----------------------------

·         Установка значений bandwidth для Serial-интерфейсов маршрутизаторов R1 и R2

R1(config)#interface Serial0/0
R1(config-if)#bandwidth 64
R1(config-if)#interface Serial0/1
R1(config-if)#bandwidth 64

R2(config)#interface Serial0/0
R2(config-if)#bandwidth 64
R2(config)#interface Serial0/1
R2(config-if)#bandwidth 64

·         Получение информации о полученном значении Cost из вывода команды show ip ospf interface.

R1#show ip ospf interface
-----------------------------пропущено----------------------------
Serial0/0 is up, line protocol is up
Internet address is 192.168.0.1/30, Area 0
Process ID 1, Router ID 10.1.1.1, Network Type POINT-TO-POINT, Cost: 1562
Transmit Delay is 1 sec, State POINT-TO-POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:05
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1 , Adjacent neighbor count is 1
Adjacent with neighbor 10.2.2.2
Suppress hello for 0 neighbor(s)
Serial0/1 is up, line protocol is up
Internet address is 192.168.0.5/30, Area 0
Process ID 1, Router ID 10.1.1.1, Network Type POINT-TO-POINT, Cost: 1562
Transmit Delay is 1 sec, State POINT-TO-POINT,
-----------------------------пропущено----------------------------

·         Установка параметра cost для Serial-интерфейсов маршрутизатора R3

R3(config)#interface Serial0/0
R3(config-if)#ip ospf cost 1562
R3(config-if)#interface Serial0/1
R3(config-if)#ip ospf cost 1562

·         Получение информации о полученном значении cost из вывода команды show ip ospf interface.



R3#show ip ospf interface
-----------------------------пропущено----------------------------
Serial0/1 is up, line protocol is up
Internet address is 192.168.0.10/30, Area 0
Process ID 1, Router ID 10.3.3.3, Network Type POINT-TO-POINT, Cost: 1562
Transmit Delay is 1 sec, State POINT-TO-POINT,
Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
Hello due in 00:00:06
Index 2/2, flood queue length 0
Next 0x0(0)/0x0(0)
Last flood scan length is 1, maximum is 1
Last flood scan time is 0 msec, maximum is 0 msec
Neighbor Count is 1 , Adjacent neighbor count is 1
Adjacent with neighbor 10.2.2.2
Suppress hello for 0 neighbor(s)
Serial0/0 is up, line protocol is up
Internet address is 192.168.0.6/30, Area 0
Process ID 1, Router ID 10.3.3.3, Network Type POINT-TO-POINT, Cost: 1562
Transmit Delay is 1 sec, State POINT-TO-POINT,
-----------------------------пропущено----------------------------

8. Настройка перераспределения маршрута по умолчанию в среду OSPF

·         На маршрутизаторе R1 настроить маршрут по умолчанию через loopback-интерфейс

R1(config)#ip route 0.0.0.0 0.0.0.0 loopback0
R1(config)#

·         Включить маршрут по умолчанию в анонсы OSPF

R1(config)#router ospf 1
R1(config-router)#default-information originate
R1(config-router)#

·         Проверить перераспределение статического маршрута по умолчанию

R2#show ip route
-----------------------------пропущено----------------------------
Gateway of last resort is 192.168.0.1 to network 0.0.0.0

10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C  10.2.2.2/32 is directly connected, Loopback0
C  10.1.1.0/24 is directly connected, FastEthernet0/0
172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O  172.16.0.16/28 [110/1563] via 192.168.0.1, 00:29:28,
Serial0/0
O  172.16.0.32/29 [110/1563] via 192.168.0.10, 00:29:28,Serial0/1
192.168.0.0/30 is subnetted, 3 subnets
C  192.168.0.0 is directly connected, Serial0/0
O  192.168.0.4 [110/3124] via 192.168.0.10, 00:25:56,Serial0/1
[110/3124] via 192.168.0.1, 00:25:56, Serial0/0
C  192.168.0.8 is directly connected, Serial0/1
O*E2 0.0.0.0/0 [110/1] via 192.168.0.1, 00:01:11, Serial0/0

R2#

Комментариев нет:

Отправить комментарий