10 мая 2013 г.

Лабораторная работа CCNA #FastPass - PPP Lab 1 Basics

Лабораторная работа CCNA #FastPass - PPP Lab 1 Basics
Лабораторная работа CCNA по теме PPP.  Данная лабораторная работа может быть выполнена на реальном оборудовании  или в Cisco Packet Tracer.  Все необходимые действия указаны по порядку их выполнения. Для начала выполнения лабораторной работы необходимо соединить физическую сеть в соответствии со схемой сети или построить соответствующий проект в Cisco Packet Tracer.  Сразу после схемы сети в таблице указана схема адресация, которую нужно применять только тогда, когда это будет явно указано в тексте лабораторной работы. 

Используемая топология
Лабораторная работа CCNA #FastPass - PPP Lab 1 Basics

План адресации
Device
Interface
IP Address
Subnet Mask
Default Gateway
R1
Fa0/1
192.168.10.1
255.255.255.0
N/A
S0/0
10.1.1.1
255.255.255.252
N/A
R2
Lo0
203.0.113.225
255.255.255.224
N/A
S0/0
10.1.1.2
255.255.255.252
N/A
S0/1
10.2.2.1
255.255.255.252
N/A
R3
Fa0/1
192.168.30.1
255.255.255.0
N/A
S0/1
10.2.2.2
255.255.255.252
N/A
PC1
NIC
192.168.10.10
255.255.255.0
192.168.10.1
PC3
NIC
192.168.30.10
255.255.255.0
192.168.30.1




1. Базовая конфигурация оборудования
·         Настроить hostname на маршрутизаторах.
·         Отключить DNS lookup.
·         Установить пароль для  EXEC mode
·         Настроить message-of-the-day banner.
·         Установить пароль для console

2. Настроить адресацию оборудования согласно плана
·         Настроить интерфейсы на R1, R2 и R3 согласно плана адресации.
·         Проверить выполненные настройки командой show ip interface brief

3. Настроить протокол динамической маршрутизации OSPF
·         Настроить  OSPF на на R1, R2 и R3
R1(config)#router ospf 1
R1(config-router)#network 192.168.10.0 0.0.0.255 area 0
R1(config-router)#network 10.1.1.0 0.0.0.3 area 0
*Aug 17 17:49:14.689: %OSPF-5-ADJCHG: Process 1, Nbr 203.0.113.225 on
Serial0/0 from LOADING to FULL, Loading Done
R1(config-router)#

R2(config)#router ospf 1
R2(config-router)#network 10.1.1.0 0.0.0.3 area 0
*Aug 17 17:48:40.645: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.1 on
Serial0/0 from LOADING to FULL, Loading Done
R2(config-router)#network 10.2.2.0 0.0.0.3 area 0
R2(config-router)#network 203.0.113.224 0.0.0.31 area 0
R2(config-router)#
*Aug 17 17:57:44.729: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on
Serial0/1 from LOADING to FULL, Loading Done
R2(config-router)#

R3(config)#router ospf 1
R3(config-router)#network 10.2.2.0 0.0.0.3 area 0
*Aug 17 17:58:02.017: %OSPF-5-ADJCHG: Process 1, Nbr 203.0.113.225 on
Serial0/1 from LOADING to FULL, Loading Done
R3(config-router)#network 192.168.30.0 0.0.0.255 area 0
R3(config-router)#

·         Проверить  работоспособность сети, используя show ip route и ping
R1#show ip route   
-----------------------------пропущено----------------------------
O
C

O

O
C
192.168.30.0/24 [110/1563] via 10.1.1.2, 00:33:56, Serial0/0
192.168.10.0/24 is directly connected, FastEthernet0/1
203.0.113.0/27 is subnetted, 1 subnets
203.0.113.225 [110/782] via 10.1.1.2, 00:33:56, Serial0/0
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
10.2.2.0/30 [110/1562] via 10.1.1.2, 00:33:56, Serial0/0
10.1.1.0/30 is directly connected, Serial0/0

R1#ping 192.168.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

R2#show ip route
-----------------------------пропущено----------------------------
O
C

O

O
C
192.168.30.0/24 [110/782] via 10.2.2.2, 00:33:04, Serial0/1
192.168.10.0/24 [110/782] via 10.1.1.1, 00:33:04, Serial0/0
203.0.113.0/27 is subnetted, 1 subnets
203.0.113.224 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 4 subnets, 2 masks
10.2.2.0/30 is directly connected, Serial0/1
10.1.1.0/30 is directly connected, Serial0/0/

R2#ping 192.168.30.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms
R2#ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms

R3#show ip route
-----------------------------пропущено----------------------------
O
C

O

O
C
192.168.30.0/24 is directly connected, FastEthernet0/1
192.168.10.0/24 [110/1563] via 10.2.2.1, 00:32:01, Serial0/1
203.0.113.0/27 is subnetted, 1 subnets
203.0.113.225 [110/782] via 10.2.2.1, 00:32:01, Serial0/1
10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
10.2.2.0/30 is directly connected, Serial0/1
10.1.1.0/30 [110/1562] via 10.2.2.1, 00:32:01, Serial0/1

R3#ping 203.0.113.225

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 203.0.113.225, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/16/16 ms
R3#ping 192.168.10.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/32/32 ms

4. Настроить PPP инкапсуляцию
·         Используя команду  show interface проверить текущее значение параметра encapsulation на serial-интерфейсах

R1#show interface Serial0/0
Serial0/0 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.1.1.1/30
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
-----------------------------пропущено----------------------------

R2#show interface serial 0/0
Serial0/0 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.1.1.2/30
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
-----------------------------пропущено----------------------------

R2#show interface serial 0/1
Serial0/1 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.2.2.1/30
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
-----------------------------пропущено----------------------------

R3#show interface serial 0/1
Serial0/1 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.2.2.2/30
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation HDLC, loopback not set
-----------------------------пропущено----------------------------

·         Используя  debug отслеживать на R1 и R2  процесс конфигурирования PPP
R1#debug ppp negotiation
PPP protocol negotiation debugging is on
R1#debug ppp packet
PPP packet display debugging is on

R2#debug ppp negotiation
PPP protocol negotiation debugging is on
R2#debug ppp packet
PPP packet display debugging is on

·         Установить PPP инкапсуляцию на serial-интерфейсах.
Изменить тип инкапсуляции на соединении между R1 и R2.

R1(config)#interface serial 0/0
R1(config-if)#encapsulation ppp
R1(config-if)#
*Aug 17 19:02:53.412: %OSPF-5-ADJCHG: Process 1, Nbr 203.0.113.225 on
Serial0/0 from FULL to DOWN, Neighbor Down: Interface down or
detached
R1(config-if)#
*Aug 17 19:02:53.416: Se0/0 PPP: Phase is DOWN, Setup
*Aug 17 19:02:53.416: Se0/0 PPP: Using default call direction
*Aug 17 19:02:53.416: Se0/0 PPP: Treating connection as a dedicated
line
*Aug 17 19:02:53.416: Se0/0 PPP: Session handle[E4000001] Session
id[0]
*Aug 17 19:02:53.416: Se0/0 PPP: Phase is ESTABLISHING, Active Open
*Aug 17 19:02:53.424: Se0/0 LCP: O CONFREQ [Closed] id 1 len 10
*Aug 17 19:02:53.424: Se0/0 LCP: MagicNumber 0x63B994DE
(0x050663B994DE)
R1(config-if)#
*Aug 17 19:02:55.412: Se0/0 PPP: Outbound cdp packet dropped
*Aug 17 19:02:55.432: Se0/0 LCP: TIMEout: State REQsent
*Aug 17 19:02:55.432: Se0/0 LCP: O CONFREQ [REQsent] id 2 len 10
*Aug 17 19:02:55.432: Se0/0 LCP: MagicNumber 0x63B994DE
(0x050663B994DE)
*Aug 17 19:02:56.024: Se0/0 PPP: I pkt type 0x008F, datagramsize 24
link[illegal]
*Aug 17 19:02:56.024: Se0/0 UNKNOWN(0x008F): Non-NCP packet,
discarding
R1(config-if)#
*Aug 17 19:02:57.252: Se0/0 PPP: I pkt type 0x000F, datagramsize 84
link[illegal]
*Aug 17 19:02:57.252: Se0/0 UNKNOWN(0x000F): Non-NCP packet,
discarding
*Aug 17 19:02:57.448: Se0/0 LCP: TIMEout: State REQsent
*Aug 17 19:02:57.448: Se0/0 LCP: O CONFREQ [REQsent] id 3 len 10
*Aug 17 19:02:57.448: Se0/0 LCP: MagicNumber 0x63B994DE
(0x050663B994DE)
R1(config-if)#
*Aug 17 19:02:58.412: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/0, changed state to down

R2(config)#interface serial 0/0
R2(config-if)#encapsulation ppp
R2(config-if)#
*Aug 17 19:06:48.848: Se0/0 PPP: Phase is DOWN, Setup
*Aug 17 19:06:48.848: Se0/0 PPP: Using default call direction
*Aug 17 19:06:48.848: Se0/0 PPP: Treating connection as a dedicated
line
*Aug 17 19:06:48.848: Se0/0 PPP: Session handle[C6000001] Session
id[0]
*Aug 17 19:06:48.848: Se0/0 PPP: Phase is ESTABLISHING, Active Open
*Aug 17 19:06:48.856: Se0/0 LCP: O CONFREQ [Closed] id 1 len 10
*Aug 17 19:06:48.856: Se0/0 LCP: MagicNumber 0x63BD388C
(0x050663BD388C)
*Aug 17 19:06:48.860: Se0/0 PPP: I pkt type 0xC021, datagramsize 14
link[ppp]
*Aug 17 19:06:48.860: Se0/0 LCP: I CONFACK [REQsent] id 1 len 10
R2(config-if)#
*Aug 17 19:06:48.860: Se0/0 LCP: MagicNumber 0x63BD388C
(0x050663BD388C)
R2(config-if)#
*Aug 17 19:06:50.864: Se0/0 LCP: TIMEout: State ACKrcvd
*Aug 17 19:06:50.864: Se0/0 LCP: O CONFREQ [ACKrcvd] id 2 len 10
*Aug 17 19:06:50.864: Se0/0 LCP: MagicNumber 0x63BD388C
(0x050663BD388C)
*Aug 17 19:06:50.868: Se0/0 PPP: I pkt type 0xC021, datagramsize 14
link[ppp]
*Aug 17 19:06:50.868: Se0/0 LCP: I CONFREQ [REQsent] id 61 len 10
*Aug 17 19:06:50.868: Se0/0 LCP: MagicNumber 0x63BDB9A8
(0x050663BDB9A8)
*Aug 17 19:06:50.868: Se0/0 LCP: O CONFACK [REQsent] id 61 len 10
*Aug 17 19:06:50.868: Se0/0 LCP: MagicNumber 0x63BDB9A8
(0x050663BDB9A8)
*Aug 17 19:06:50.868: Se0/0 PPP: I pkt type 0xC021, datagramsize 14
link[ppp]
*Aug 17 19:06:50.868: Se0/0 LCP: I CONFACK [ACKsent] id 2 len 10
*Aug 17 19:06:50.868: Se0/0 LCP: MagicNumber 0x63BD388C
(0x050663BD388C)
*Aug 17 19:06:50.868: Se0/0 LCP: State is Open
*Aug 17 19:06:50.872: Se0/0 PPP: Phase is FORWARDING   , Attempting
Forward
*Aug 17 19:06:50.872: Se0/0 PPP: Phase is ESTABLISHING    , Finish LCP
*Aug 17 19:06:50.872: Se0/0 PPP: Phase is UP
*Aug 17 19:06:50.872: Se0/0 IPCP: O CONFREQ [Closed] id 1 len 10
*Aug 17 19:06:50.872: Se0/0 IPCP: Address 10.1.1.2
(0x03060A010102)
*Aug 17 19:06:50.872: Se0/0 CDPCP: O CONFREQ [Closed] id 1 len 4
*Aug 17 19:06:50.872: Se0/0 PPP: Process pending ncp packets
*Aug 17 19:06:50.876: Se0/0 PPP: I pkt type 0x8021, datagramsize 14
link[ip]
*Aug 17 19:06:50.876: Se0/0 IPCP: I CONFREQ [REQsent] id 1 len 10
*Aug 17 19:06:50.876: Se0/0 IPCP: Address 10.1.1.1
(0x03060A010101)
*Aug 17 19:06:50.876: Se0/0 PPP: I pkt type 0x8207, datagramsize 8
link[cdp]
*Aug 17 19:06:50.876: Se0/0 IPCP: O CONFACK [REQsent] id 1 len 10
*Aug 17 19:06:50.876: Se0/0 IPCP: Address 10.1.1.1
(0x03060A010101)
*Aug 17 19:06:50.876: Se0/0 CDPCP: I CONFREQ [REQsent] id 1 len 4
*Aug 17 19:06:50.876: Se0/0 CDPCP: O CONFACK [REQsent] id 1 len 4
*Aug 17 19:06:50.876: Se0/0 PPP: I pkt type 0x8021, datagramsize 14
link[ip]
*Aug 17 19:06:50.876: Se0/0 IPCP: I CONFACK [ACKse
R2(config-if)#nt] id 1 len 10
*Aug 17 19:06:50.876: Se0/0 IPCP: Address 10.1.1.2
(0x03060A010102)
*Aug 17 19:06:50.876: Se0/0 IPCP: State is Open
*Aug 17 19:06:50.876: Se0/0 PPP: I pkt type 0x8207, datagramsize 8
link[cdp]
*Aug 17 19:06:50.876: Se0/0 IPCP: Install route to 10.1.1.1
*Aug 17 19:06:50.880: Se0/0 CDPCP: I CONFACK [ACKsent] id 1 len 4
*Aug 17 19:06:50.880: Se0/0 CDPCP: State is Open
*Aug 17 19:06:50.880: Se0/0 PPP: O pkt type 0x0021, datagramsize 80
*Aug 17 19:06:50.880: Se0/0 IPCP: Add link info for cef entry
10.1.1.1
*Aug 17 19:06:50.884: Se0/0 PPP: I pkt type 0x0021, datagramsize 80
link[ip]
*Aug 17 19:06:51.848: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/0, changed state to up
R2(config-if)#
*Aug 17 19:06:51.888: Se0/0 LCP-FS: I ECHOREQ [Open] id 1 len 12
magic 0x63BDB9A8
*Aug 17 19:06:51.888: Se0/0 LCP-FS: O ECHOREP [Open] id 1 len 12
magic 0x63BD388C

-----------------------------пропущено----------------------------

*Aug 17 19:07:00.936: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.1 on
Serial0/0 from LOADING to FULL, Loading Done

Отключить  debug

R1#undebug all
Port Statistics for unclassified packets is not turned on.

All possible debugging has been turned off
R1#

R2#undebug all
Port Statistics for unclassified packets is not turned on.

All possible debugging has been turned off
R2#

Изменить тип инкапсуляции на соединении между R2 и R3
R2(config)#interface Serial0/1
R2(config-if)#encapsulation ppp
R2(config-if)#
*Aug 17 20:02:08.080: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on
Serial0/1 from FULL to DOWN, Neighbor Down: Interface down or
detached
R2(config-if)#
*Aug 17 20:02:13.080: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/1, changed state to down
R2(config-if)#
*Aug 17 20:02:58.564: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/1, changed state to up
R2(config-if)#
*Aug 17 20:03:03.644: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on
Serial0/1 from LOADING to FULL, Loading Done
R2(config-if)#
*Aug 17 20:03:46.988: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/1, changed state to down

R3(config)#interface serial 0/1
R3(config-if)#encapsulation ppp
R3(config-if)#
*Aug 17 20:04:27.152: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/1, changed state to up
*Aug 17 20:04:30.952: %OSPF-5-ADJCHG: Process 1, Nbr 203.0.113.225 on
Serial0/1 from LOADING to FULL, Loading Done

·         Проверить полученную конфигурацию

R1#show interface Serial0/0
Serial0/0 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.1.1.1/30
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open
Open: CDPCP, IPCP, loopback not set
-----------------------------пропущено----------------------------

R2#show interface serial 0/0
Serial0/0 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.1.1.2/30
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open
Open: CDPCP, IPCP, loopback not set
-----------------------------пропущено----------------------------

R2#show interface serial 0/1
Serial0/1 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.2.2.1/30
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open
Open: CDPCP, IPCP, loopback not set
-----------------------------пропущено----------------------------

R3#show interface serial 0/1
Serial0/1 is up, line protocol is up
Hardware is GT96K Serial
Internet address is 10.2.2.2/30
MTU 1500 bytes, BW 128 Kbit, DLY 20000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation PPP, LCP Open
Open: CDPCP, IPCP, loopback not set
-----------------------------пропущено----------------------------

5. Настроить PPP Authentication

·         Настроить  PPP PAP authentication на соединении между R1 и R2.

R1(config)#username R1 password cisco
R1(config)#int S0/0
R1(config-if)#ppp authentication pap
R1(config-if)#
*Aug 22 18:58:57.367: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/0, changed state to down
R1(config-if)#
*Aug 22 18:58:58.423: %OSPF-5-ADJCHG: Process 1, Nbr 203.0.113.225 on
Serial0/0 from FULL to DOWN, Neighbor Down: Interface down or
detached
R1(config-if)#ppp pap sent-username R2 password cisco

R2(config)#username R2 password cisco
R2(config)#interface Serial0/0
R2(config-if)#ppp authentication pap
R2(config-if)#ppp pap sent-username R1 password cisco
R2(config-if)#
*Aug 23 16:30:33.771: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/0, changed state to up
R2(config-if)#
*Aug 23 16:30:40.815: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.10.1 on
Serial0/0 from LOADING to FULL , Loading Done
R2(config-if)#

·          Настроить  PPP CHAP authentication на соединении между R2 и R3.

R2(config)#username R3 password cisco
R2(config)#int S0/1
R2(config-if)#ppp authentication chap
R2(config-if)#
*Aug 23 18:06:00.935: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/1, changed state to down
R2(config-if)#
*Aug 23 18:06:01.947: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.30.1 on
Serial0/1 from FULL to DOWN, Neighbor Down: Interface down or
detached
R2(config-if)#

R3(config)#username R2 password cisco
*Aug 23 18:07:13.074: %LINEPROTO-5-UPDOWN: Line protocol on Interface
Serial0/1, changed state to up
R3(config)#int S0/1
R3(config-if)#
*Aug 23 18:07:22.174: %OSPF-5-ADJCHG: Process 1, Nbr 203.0.113.225 on
Serial0/1 from LOADING to FULL, Loading Done
R3(config-if)#ppp authentication chap
R3(config-if)#

Комментариев нет:

Отправить комментарий