24 мая 2010 г.

Лабораторная работа №10 Establishing a Telnet or SSH Connection курса CISCO CCNA 640 - 802

CISCO CCNA 640 - 802 Лабораторная работа
Целью данной лабораторной работы является ознакомление с  основными функциями удаленного администрирования оборудования CISCO с использованием telnet и ssh  При выполнении будет использоваться GNS3 / Cisco 2961. После выполнения лабораторной работы будут закреплены базовые навыки использования telnet и ssh на оборудовании CISCO
Простая топология, которая будет использоваться при выполнении лабораторной работы.

Объект Cloud (C1) представляет подключение host-компьютера к эмулируемой топологии (описание).
Для подключения  по протоколу ssh необходимо предварительно настроить маршрутизаторы R1 и R2 как описано здесь.



Предварительная настройка маршрутизатора R1

router>enable
router#configure terminal



1. Настроить сетевые интерфейсы 
router(config)#interface FastEthernet 0/0
router(config-if)#ip address 192.168.254.254 255.255.255.0
router(config-if)#no shutdown

router(config-if)#exit

router(config)#interface FastEthernet 0/1router(config-if)#ip address 192.168.253.1 255.255.255.0
router(config-if)#no shutdown
 

router(config-if)#exit


2. Настроить hostname и domain name
router(config)hostname R1
R1(config)#ip domain-name localdomain


3. Установить пароль на Priveleged EXEC 
R1(config)#enable password enablepassword 
R1(config)#enable secret enablesecret

4. Добавить пользователя

R1(config)#username sshuser password 0 sshpassword

5. Сгенерировать RSA-ключ
R1(config)#crypto key generate rsa

How many bits in the modulus [512]: 768  - необходимо для использования второй версии протокола



6. Активировать использование SSH 2-й версии 
R1(config)#ip ssh version 2


7. Настроить доступ к виртуальным терминалам только с использованием SSH
R1(config)#line vty 0 4

R1(config-line)#login local
R1(config-line)#transport input telnet ssh







8. Сохранить конфигурациюR1#copy running-config startup-config
или
R1#copy run start
или
R1#write memory



Предварительная настройка маршрутизатора R2

router>enable
router#configure terminal


1. Настроить сетевые интерфейсы  
router(config)#interface FastEthernet 0/0
router(config-if)#ip address 192.168.253.254 255.255.255.0
router(config-if)#no shutdown


router(config-if)#exit


2. Настроить hostname и domain name
router(config)hostname R2
R2(config)#ip domain-name localdomain

3. Установить пароль на Priveleged EXEC 
R2(config)#enable password enablepassword 
R2(config)#enable secret enablesecret

4. Добавить пользователя
R2(config)#username sshuser password 0 sshpassword

5. Сгенерировать RSA-ключ
R2(config)#crypto key generate rsa

How many bits in the modulus [512]: 768  - необходимо для использования второй версии протокола


6. Активировать использование SSH 2-й версии 
R2(config)#ip ssh version 2

7. Настроить доступ к виртуальным терминалам только с использованием SSH
R2(config)#line vty 0 4

R2(config-line)#login local 
R2(config-line)#transport input telnet ssh

R2(config-line)#exit
R2(config)#exit

 



8. Сохранить конфигурацию 
R2#copy running-config startup-config
или
R2#copy run start
или
R2#write memory
  
Подключение к маршрутизатору R2 с использованием telnet

R1>telnet 192.168.253.254

для маршрутизаторов можно просто 

R1>192.168.253.254

Возврат в локальную консоль

Нажать [Ctrl] + [Shift] + 6  ( [Ctrl] + ^ ), после чего нажать x

Просмотр списка сессий в локальной консоли
R1>show sessions

Возобновление последней сессии 
R1> resume

Просмотр подключенных пользователей на R2

R2>show users  
Отключение от роутера R2

R2>logout
или 
R2>exit

Обрываем сессию из локальной консоли

 R1>disconnect 1         (1 получено из вывода show sessions)

В локальной консоли R2 выполняем privileged EXEC команду

R2#clear line vty 0          ( 0 получаем из вывода show users)



Подключение к маршрутизатору R2 с использованием ssh

R1#enable
Password: 
R1#ssh -l sshuser -v 2 192.168.253.254
 

R2#show ssh  
 
        Connection Version Mode Encryption Hmac State Username
        66              1.99            IN         aes128-cbc         hmac-sha1        Session started      sshuser
        66              1.99            OUT     aes128-cbc         hmac-sha1        Session started      sshuser
        %No SSHv1 server connections running.

 


 

5 комментариев:

Анонимный комментирует...

Сделано и перепроверено по приведенному вами алгоритму, просмотр настроек маршрутизаторов показывает, что нужный интерфейс поднят, в топологии связь по FastEthernet между роутерами сделана. Но соединения ни по telnety, ни по ssh, ни даже пинга нет. Что-то в настройках программы надо еще сделать может?

Dave комментирует...

Какая операционная система на хост-компьютере?

Анонимный комментирует...

проверяли на ХР и 7

Dave комментирует...

Если не проходят icmp, telnet-ом бесполезно ломиться.
Я сейчас смотрю на эту лабораторную работу и понимаю, что уж слишком сильно я ее усложнил для того чтобы просто перебраться telnet-ом с роутера на роутер. Уточните пожалуйста откуда куда не идет icmp. Между хост компьютером и роутером подключенным к объекту cloud или между маршрутизаторами в проекте?

Анонимный комментирует...

между роутерами. При рокировке интерфейсов FastEthernet 0/1 и FastEthernet 0/0 на первом роутере связь появилась:пинг проходит, телнет тоже. ssh не пашет обе версии.

Отправить комментарий