27 ноября 2010 г.

Лабораторная работа №19 Per-VLAN Rapid Spanning Tree Plus ( PVRST+ ) курса CISCO CCNA 640 - 802

Лабораторная работа CCNA Cisco Packet Tracer GNS3
Целью данной лабораторной работы является анализ и настройка конфигурации Per-VLAN Rapid Spanning Tree Plus ( PVRST+ ), а также закрепить навыки настройки VLAN Trunking Protocol ( VTP ). При выполнении будет использоваться Cisco Packet Tracer 5.3. После выполнения лабораторной работы будут получены знания по базовым командам для настройки и диагностики  PVRST+ на оборудования CISCO, закреплены навыки конфигурирования VTP, а также навыки базовой конфигурации оборудования Cisco.

 Используемая топологи сети
 Лабораторная работа CCNA Cisco Packet Tracer GNS3

План адресации
Лабораторная работа CCNA Cisco Packet Tracer GNS3
  
Назначения портов на Sw2
Лабораторная работа CCNA Cisco Packet Tracer GNS3

1. Выполнить базовую конфигурацию
2. Выполнить конфигурацию VTP
3. Выполнить конфигурацию native VLAN и trunk-ов
4. Выполнить настройку VLAN-ов
5. Выполнить дополнительную настройку RSTP

1. Выполнить базовую конфигурацию
Sw1
Switch>enable
Switch#configure terminal
Switch(config)#hostname Sw1
Sw1(config)#no ip domain lookup
Sw1(config)#enable secret cisco2
Sw1(config)#line console 0
Sw1(config-line)#logging synchronous
Sw1(config-line)#password cisco1
Sw1(config-line)#login
Sw1(config-line)#exit
Sw1(config)#line vty 0 15
Sw1(config-line)#logging synchronous
Sw1(config-line)#password cisco3
Sw1(config-line)#login
Sw1(config-line)#end
Sw1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
 
Sw2
Switch>enable
Switch#configure terminal
Switch(config)#hostname Sw2
Sw2(config)#no ip domain lookup
Sw2(config)#enable secret cisco2
Sw2(config)#line console 0
Sw2(config-line)#logging synchronous
Sw2(config-line)#password cisco1
Sw2(config-line)#login
Sw2(config-line)#exit
Sw2(config)#line vty 0 15
Sw2(config-line)#logging synchronous
Sw2(config-line)#password cisco3
Sw2(config-line)#login
Sw2(config-line)#end
Sw2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw3
Switch>enable
Switch#configure terminal
Switch(config)#hostname Sw3
Sw3(config)#no ip domain lookup
Sw3(config)#enable secret cisco2
Sw3(config)#line console 0
Sw3(config-line)#logging synchronous
Sw3(config-line)#password cisco1
Sw3(config-line)#login
Sw3(config-line)#exit
Sw3(config)#line vty 0 15
Sw3(config-line)#logging synchronous
Sw3(config-line)#password cisco3
Sw3(config-line)#login
Sw3(config-line)#end
Sw3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
2. Выполнить конфигурацию VTP

Sw1
Sw1#configure terminal 
Sw1(config)#vtp mode server
Sw1(config)#vtp domain CcnaLab19
Sw1(config)#vtp password cisco4
Sw1(config)#exit
Sw1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

 
Sw2
Sw2#configure terminal
Sw2(config)#vtp mode client
Sw2(config)#vtp domain CcnaLab19
Sw2(config)#vtp password cisco4
Sw2(config)#exit
Sw2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Sw3
Sw3#configure terminal 
Sw3(config)#vtp mode client
Sw3(config)#vtp domain CcnaLab19
Sw3(config)#vtp password cisco4
Sw3(config)#exit
Sw3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

3. Выполнить конфигурацию native VLAN и trunk-ов
 
Sw1

Sw1#configure terminal
Sw1(config)#interface range f0/1 - 4
Sw1(config-if-range)#switchport mode trunk
Sw1(config-if-range)#switchport trunk native vlan 99
Sw1(config-if-range)#exit
Sw1(config)#interface vlan 99
Sw1(config-if)#ip address 172.17.99.11 255.255.255.0
Sw1(config-if)#no shutdown
Sw1(config-if-range)#do copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw1(config-if-range)#end
Sw2


Sw2#configure terminal
Sw2(config)#interface range f0/1 - 4
Sw2(config-if-range)#switchport mode trunk
Sw2(config-if-range)#switchport trunk native vlan 99

Sw2(config-if-range)#exit
Sw2(config)#interface vlan 99
Sw2(config-if)#ip address 172.17.99.12 255.255.255.0
Sw2(config-if)#no shutdown

Sw2(config-if-range)#do copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw2(config-if-range)#end
Sw3 

Sw3#configure terminal
Sw3(config)#interface range f0/1 - 4
Sw3(config-if-range)#switchport mode trunk
Sw3(config-if-range)#switchport trunk native vlan 99
Sw3(config-if-range)#exit
Sw3(config)#interface vlan 99
Sw3(config-if)#ip address 172.17.99.13 255.255.255.0
Sw3(config-if)#no shutdown
Sw3(config-if-range)#do copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw3(config-if-range)#end

4. Выполнить настройку VLAN-ов
Sw1
Sw1#configure terminal
Sw1(config)#vlan 10
Sw1(config-vlan)#name Staff
Sw1(config-vlan)#exit
Sw1(config)#vlan 20
Sw1(config-vlan)#name Students
Sw1(config-vlan)#exit
Sw1(config)#vlan 30
Sw1(config-vlan)#name Guests
Sw1(config-vlan)#exit
Sw1(config)#exit
Sw1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Проверить добавление и распределение VLAN-ов в VTP домене можно командой show vlan brief на Sw1, Sw2 и Sw3. 
Sw2 
Sw2#configure terminal
Sw2(config)#interface range f0/5 - 8
Sw2(config-if-range)#
Sw2(config-if-range)#switchport mode access
Sw2(config-if-range)#switchport access vlan 30
Sw2(config-if-range)#no shutdown
Sw2(config-if-range)#exit
Sw2(config)#interface range f0/9 - 12
Sw2(config-if-range)#switchport mode access
Sw2(config-if-range)#switchport access vlan 10
Sw2(config-if-range)#no shutdown
Sw2(config-if-range)#exit
Sw2(config)#interface range f0/13 - 15
Sw2(config-if-range)#switchport mode access
Sw2(config-if-range)#switchport access vlan 20
Sw2(config-if-range)#no shutdown
Sw2(config-if-range)#exit
Sw2(config)#exit
Sw2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
5. Выполнить настройку RSTP 
Sw1
Sw1#configure terminal
Sw1(config)#spanning-tree mode rapid-pvst
Sw1(config)#exit
Sw1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw2
Sw2#configure terminal
Sw2(config)#spanning-tree mode rapid-pvst
Sw2(config)#exit
Sw2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Sw3
Sw3#configure terminal
Sw3(config)#spanning-tree mode rapid-pvst
Sw3(config)#exit
Sw3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Проверить настройки режима STP можно командой show spanning-tree summary . В первой строке вывода данной команды должно быть Switch is in rapid-pvst mode.

3 комментария:

Анонимный комментирует...

Ну и эту лабораторную работу тоже лучше не в GNS3, а Cisco Packet Tracer. Все таки Packet Tracer трудно заменить при подготовке к экзамену CCNA

Анонимный комментирует...

GNS3 только для настройки роутеров.CLI свитчей там не встретишь))

Михаил комментирует...

Да ладно. Берешь в GNS3 3640, 3725 и втыкаешь swith плату. Все дела)))

Отправить комментарий