26 ноября 2010 г.

Лабораторная работа №18 Per-VLAN Spanning Tree Protocol Plus ( PVST+ ) курса CISCO CCNA 640 - 802

Лабораторная работа CCNA Cisco Packet Tracer GNS3
Целью данной лабораторной работы является анализ и настройка конфигурации Per-VLAN Spanning Tree Protocol Plus ( PVST+ ), а также закрепить навыки настройки VLAN Trunking Protocol ( VTP ) . При выполнении может использоваться как Cisco Packet Tracer 5.3 так и GNS3. После выполнения лабораторной работы будут получены знания по базовым командам для настройки и диагностики   PVST+  на оборудования CISCO, закреплены навыки конфигурирования VTP, а также навыки базовой конфигурации оборудования Cisco.

Используемая топологи сети
Лабораторная работа CCNA Cisco Packet Tracer GNS3

План адресации
Лабораторная работа CCNA Cisco Packet Tracer GNS3 
Назначения портов на Sw2
Лабораторная работа CCNA Cisco Packet Tracer GNS3
1. Выполнить базовую конфигурацию
2. Выполнить конфигурацию VTP
3. Выполнить конфигурацию native VLAN и trunk-ов
4. Выполнить настройку VLAN-ов
5. Выполнить дополнительную настройку STP

1. Выполнить базовую конфигурацию
Sw1
Router>enable
Router#configure terminal
Router(config)#hostname Sw1
Sw1(config)#no ip domain lookup
Sw1(config)#enable secret cisco2
Sw1(config)#line console 0
Sw1(config-line)#logging synchronous
Sw1(config-line)#password cisco1
Sw1(config-line)#login
Sw1(config-line)#exit
Sw1(config)#line vty 0 15
Sw1(config-line)#logging synchronous
Sw1(config-line)#password cisco3
Sw1(config-line)#login
Sw1(config-line)#end
Sw1#copy running-config startup-config
Sw1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
 Sw2
Router>enable
Router#configure terminal
Router(config)#hostname Sw2
Sw2(config)#no ip domain lookup
Sw2(config)#enable secret cisco2
Sw2(config)#line console 0
Sw2(config-line)#logging synchronous
Sw2(config-line)#password cisco1
Sw2(config-line)#login
Sw2(config-line)#exit
Sw2(config)#line vty 0 15
Sw2(config-line)#logging synchronous
Sw2(config-line)#password cisco3
Sw2(config-line)#login
Sw2(config-line)#end
Sw2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]  
Sw3 
Router>enable
Router#configure terminal
Router(config)#hostname Sw3
Sw3(config)#no ip domain lookup
Sw3(config)#enable secret cisco2
Sw3(config)#line console 0
Sw3(config-line)#logging synchronous
Sw3(config-line)#password cisco1
Sw3(config-line)#login
Sw3(config-line)#exit
Sw3(config)#line vty 0 15
Sw3(config-line)#logging synchronous
Sw3(config-line)#password cisco3
Sw3(config-line)#login
Sw3(config-line)#end
Sw3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

2. Выполнить конфигурацию VTP
Так как лабораторная работа выполняется в GNS3, то нужно помнить о различиях в конфигурировании VTP на маршрутизаторах с модулем NM-16ESW. На данный момент, когда VTP не является основной темой лабораторной работ возможно использование GNS3 несмотря на описанные ранее отличия.
Параметры VTP
Лабораторная работа CCNA Cisco Packet Tracer GNS3
 Sw1
Sw1#vlan database
Sw1(vlan)#vtp server
Sw1(vlan)#vtp domain CcnaLab18
Sw1(vlan)#vtp password cisco4



Sw2
Sw2#vlan database
Sw2(vlan)#vtp client
Sw2(vlan)#vtp domain CcnaLab18
Sw2(vlan)#vtp password cisco4

Sw3
Sw3#vlan database
Sw3(vlan)#vtp client
Sw3(vlan)#vtp domain CcnaLab18
Sw3(vlan)#vtp password cisco4

3. Выполнить конфигурацию native VLAN и trunk-ов
Sw1 
Так как лабораторная работа выполняется не на свитче, то перед использованием native vlan 99 нужно создать его на Sw1. На маршрутизаторах это не происходит автоматически.

Sw1#vlan database
Sw1(vlan)#vlan 99 name managment
Sw1(vlan)#apply
Sw1(vlan)#exit
Sw1#configure terminal
Sw1(config)#interface range f0/1 - 4
Sw1(config-if-range)#switchport mode trunk
Sw1(config-if-range)#switchport trunk native vlan 99
Sw1(config-if-range)#no shutdown
Sw1(config-if-range)#exit
Sw1(config)#interface vlan99
Sw1(config-if)#ip address 172.17.99.11 255.255.255.0
Sw1(config-if)#no shutdown
Sw1(config-if-range)#end

Sw2
Sw2#configure terminal
Sw2(config)#interface range f0/1 - 4
Sw2(config-if-range)#switchport mode trunk
Sw2(config-if-range)#switchport trunk native vlan 99
Sw2(config-if-range)#no shutdown
Sw2(config-if-range)#exit
Sw2(config-if)#ip address 172.17.99.12 255.255.255.0
Sw2(config-if)#no shutdown
Sw2(config-if-range)#end 

Sw3
Sw3(config)#interface range f0/1 - 4
Sw3(config-if-range)#switchport mode trunk
Sw3(config-if-range)#switchport trunk native vlan 99
Sw3(config-if-range)#no shutdown
Sw3(config-if-range)#exit

Sw3(config-if)#ip address 172.17.99.13 255.255.255.0
Sw3(config-if)#no shutdown
Sw3(config-if-range)#end 


4. Выполнить настройку VLAN-ов
VTP VLAN-ы настраиваются только на Sw1, так как он в данном VTP домене находится в режиме Server.  Так как в качестве коммутатора второго уровня используется маршрутизатор с модулем NM-16ESW,  процесс добавления VLAN-ов будет отличаться от того как это делается на свитчах Cisco.

Sw1
Sw1#vlan database
Sw1(vlan)#vlan 10 name Staff
Sw1(vlan)#vlan 20 name Students
Sw1(vlan)#vlan 30 name Guests
Sw1(vlan)#apply

Проверить добавление и распределение  
VLAN-ов в VTP домене можно командой show vlan-switch brief на Sw1, Sw2 и Sw3. Это немного отличается от того, как это было бы сделано на свитче ( show vlan brief ).

Sw2
Sw2(config)#interface range f0/5 - 8
Sw2(config-if-range)#switchport mode access
Sw2(config-if-range)#switchport access vlan 30
Sw2(config-if-range)#no shutdown
Sw2(config-if-range)#exit
Sw2(config)#interface range f0/9 - 12
Sw2(config-if-range)#switchport mode access
Sw2(config-if-range)#switchport access vlan 10
Sw2(config-if-range)#no shutdown
Sw2(config-if-range)#exit
Sw2(config)#interface range f0/13 - 15
Sw2(config-if-range)#switchport mode access
Sw2(config-if-range)#switchport access vlan 20
Sw2(config-if-range)#no shutdown
Sw2(config-if-range)#end

5. Выполнить дополнительную настройку STP
Перед тем как  проводить какие-либо манипуляции с конфигурацией STP, нужно ознакомиться с текущей конфигурацией на Sw1, Sw2 и Sw3,  как это было описано в предыдущей лабораторной работе по STP, используя show spanning-tree brief. К сожалению в выводе этой команды не видно PVST+  Bridge ID Priority, который состоит из  priority  +  sys-id-ext ( Vlan id ). Основная задача выяснить роль каждой единицы оборудования в STP - топологии и состояние портов. В моем случае получилось так:

Лабораторная работа CCNA Cisco Packet Tracer GNS3
Root - бридж и состояние портов идентично для всех VLAN-ов.  Так как PVST+ подразумевает отдельный экземпляр STP на каждый VLAN, существует возможность оптимизации работы STP.
Предположим что у Sw2 более высокая производительность и нужно чтобы он стал Root-бридж для VLAN 10, VLAN 20 и VLAN 30.
Sw2
Sw2#configure terminal
Sw2(config)#spanning-tree vlan 10 priority 4096
Sw2(config)#spanning-tree vlan 20 priority 4096
Sw2(config)#spanning-tree vlan 30 priority 4096
Sw2(config)#exit

Анализируем состояние STP - топологии при помощи show spanning-tree brief. Для VLAN 10 и VLAN 99 топология не поменялась и идентична приведенной на рисунке ранее, а для VLAN 10, VLAN 20 и VLAN 30 будет выглядеть так: 

Лабораторная работа CCNA Cisco Packet Tracer GNS3

Для того, чтобы вернуть для  Sw2 значения приоритета по умолчанию

Sw2(config)#no spanning-tree vlan 10 priority
Sw2(config)#no spanning-tree vlan 20 priority
Sw2(config)#no spanning-tree vlan 30 priority


Отслеживать поведение оборудования в процессе изменения приоритетов и топологии STP можно также, как это было описано в Лабораторной работе №17,  через debug spanning-tree events 

7 комментариев:

Tigg комментирует...

Не знаю, стоило ли делать эту лабораторную работу в GNS3. Может стоило бы ее сделать в Cisco Packet Tracer? А то как-то не все очевидно из того на что нужно было обратить внимание...

Dave комментирует...

Можно и в Cisco Packet Tracer сделать. Кстати, можно просто взять и повторить этот же сценарий в нем.

Анонимный комментирует...

В packet tracer STP работает некорректно.

Анонимный комментирует...

А если для различных VLAN состояния портов отличаются, это норм ?

Dave комментирует...

Вполне. Более того это можно использовать для балансирования нагрузки.

Анонимный комментирует...

Как отменить команду: no spanning-tree vlan 10?
conf t
spanning-tree vlan 10 - не помогает!
Необходимо включить spanning-tree.

Dave комментирует...

Только что проверил. Spanning Tree без каких-либо проблем включается и выключается. Если подобная проблема возникает в Cisco Packet Tracer, то нужно сохранить проект на текущем этапе выполнения лабораторной работы, перезагрузить Cisco Packet Tracer, и попробовать повторить действия по включению и отклюению алгоритма spanning tree на выбраном vlan. Cisco Packet Tracer, очень редко, но "чудит".

Отправить комментарий