18 ноября 2010 г.

Лабораторная работа №17 Basic Spanning Tree Protocol ( STP ) в GNS3 курса CISCO CCNA 640 - 802

GNS3 STP Cisco CCNA 640-802
Целью данной лабораторной работы является анализ конфигурации и работы   Basic Spanning Tree Protocol ( STP ) . При выполнении будет использоваться GNS3 и свитч на базе модуля NM-16ESW. Использование GNS3 и реальных образов Cisco IOS во время выполнения лабораторных работ по switching позволит проверить на практике некоторые диагностические команды, недоступные в Cisco Packet Tracer.
Данная лабораторная работа подобна  Лабораторной работе №16 Basic Spanning Tree Protocol ( STP ).
Используемая топология
GNS3 STP Cisco CCNA 640-802 
Анализ Basic Spanning Tree Protocol ( STP )
1. Выполнить базовую конфигурацию для Sw1, Sw2, Sw3, Sw4
2. Выполнить конфигурацию сетевых параметров для Sw1, Sw2, Sw3, Sw4
3. Проанализировать конфигурацию STP
4. Проанализировать работу STP 

1. Выполнить базовую конфигурацию.   
Sw1
Router>enable
Router#configure terminal
Router(config)#hostname Sw1
Sw1(config)#no ip domain lookup
Sw1(config)#enable secret cisco
Sw1(config)#line console 0
Sw1(config-line)#logging synchronous
Sw1(config-line)#password cisco2
Sw1(config-line)#login
Sw1(config-line)#exit
Sw1(config)#line vty 0 15
Sw1(config-line)#logging synchronous
Sw1(config-line)#password cisco3
Sw1(config-line)#login
Sw1(config-line)#end
Sw1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Sw2
Router>enable
Router#configure terminal
Router(config)#hostname Sw2
Sw2(config)#no ip domain lookup
Sw2(config)#enable secret cisco
Sw2(config)#line console 0
Sw2(config-line)#logging synchronous
Sw2(config-line)#password cisco2
Sw2(config-line)#login
Sw2(config-line)#exit
Sw2(config)#line vty 0 15
Sw2(config-line)#logging synchronous
Sw2(config-line)#password cisco3
Sw2(config-line)#login
Sw2(config-line)#end
Sw2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw3
Router>enable
Router#configure terminal
Router(config)#hostname Sw3
Sw3(config)#no ip domain lookup
Sw3(config)#enable secret cisco
Sw3(config)#line console 0
Sw3(config-line)#logging synchronous
Sw3(config-line)#password cisco2
Sw3(config-line)#login
Sw3(config-line)#exit
Sw3(config)#line vty 0 15
Sw3(config-line)#logging synchronous
Sw3(config-line)#password cisco3
Sw3(config-line)#login
Sw3(config-line)#end
Sw3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Sw4
Router>enable
Router#configure terminal
Router(config)#hostname Sw4
Sw4(config)#no ip domain lookup
Sw4(config)#enable secret cisco
Sw4(config)#line console 0
Sw4(config-line)#logging synchronous
Sw4(config-line)#password cisco2
Sw4(config-line)#login
Sw4(config-line)#exit
Sw4(config)#line vty 0 15
Sw4(config-line)#logging synchronous
Sw4(config-line)#password cisco3
Sw4(config-line)#login
Sw4(config-line)#end
Sw4#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

2. Выполнить конфигурацию сетевых параметров
Sw1
Sw1(config)#interface range FastEthernet0/1 - 15
Sw1(config-if-range)#shutdown
Sw1config-if-range)#exit
Sw1(config)#interface range FastEthernet0/1 - 3
Sw1(config-if-range)#switchport mode trunk
Sw1(config-if-range)#no shutdown
Sw1(config-if-range)#exit
Sw1(config)#interface range FastEthernet0/4 - 6
Sw1(config-if-range)#switchport mode access
Sw1(config-if-range)#no shutdown
Sw1(config-if-range)#exit
Sw1(config)#interface VLAN 1
Sw1(config-if)#ip address 192.168.10.1 255.255.255.0
Sw1(config-if)#end
Sw1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK] 

Sw2 
Sw2(config)#interface range FastEthernet0/1 - 15
Sw2(config-if-range)#shutdown
Sw2(config-if-range)#exit
Sw2(config)#interface range FastEthernet0/1 - 3
Sw2(config-if-range)#switchport mode trunk
Sw2(config-if-range)#no shutdown
Sw2(config-if-range)#exit
Sw2(config)#interface range FastEthernet0/4 - 6
Sw2(config-if-range)#switchport mode access
Sw2(config-if-range)#no shutdown
Sw2(config-if-range)#exit
Sw2(config)#interface VLAN 1
Sw2(config-if)#ip address 192.168.10.2 255.255.255.0
Sw2(config-if)#end
Sw2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK] 

Sw3 
Sw3(config)#interface range FastEthernet0/1 - 15
Sw3(config-if-range)#shutdown
Sw3(config-if-range)#exit
Sw3(config)#interface range FastEthernet0/1 - 3
Sw3(config-if-range)#switchport mode trunk
Sw3(config-if-range)#no shutdown
Sw3(config-if-range)#exit
Sw3(config)#interface range FastEthernet0/4 - 6
Sw3(config-if-range)#switchport mode access
Sw3(config-if-range)#no shutdown
Sw3(config-if-range)#exit
Sw3(config)#interface VLAN 1
Sw3(config-if)#ip address 192.168.10.3 255.255.255.0
Sw3(config-if)#end
Sw3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK] 
Sw4
Sw4(config)#interface range FastEthernet0/1 - 15
Sw4(config-if-range)#shutdown
Sw4(config-if-range)#exit
Sw4(config)#interface range FastEthernet0/1 - 3
Sw4(config-if-range)#switchport mode trunk
Sw4(config-if-range)#no shutdown
Sw4(config-if-range)#exit
Sw4(config)#interface range FastEthernet0/4 - 6
Sw4(config-if-range)#switchport mode access
Sw4(config-if-range)#no shutdown
Sw4(config-if-range)#exit
Sw4(config)#interface VLAN 1
Sw4(config-if)#ip address 192.168.10.4 255.255.255.0
Sw4(config-if)#end
Sw4#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK] 
3. Проанализировать конфигурацию STP 
Вывод и листинг команд несколько отличается от того что было в  Лабораторной работе №16
Sw1
Sw1#show spanning-tree brief

VLAN1
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address cc00.0ca0.0000
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768
Address cc00.0ca0.0000
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1 128.2 128 19 FWD 0 32768 cc00.0ca0.0000 128.2
FastEthernet0/2 128.3 128 19 FWD 0 32768 cc00.0ca0.0000 128.3
FastEthernet0/3 128.4 128 19 FWD 0 32768 cc00.0ca0.0000 128.4
Sw2 
 Sw2#show spanning-tree brief

VLAN1
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address cc00.0ca0.0000
Cost 19
Port 3 (FastEthernet0/2)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768
Address cc02.0ca0.0000
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1 128.2 128 19 BLK 19 32768 cc01.0ca0.0000 128.3
FastEthernet0/2 128.3 128 19 FWD 0 32768 cc00.0ca0.0000 128.2
FastEthernet0/3 128.4 128 19 FWD 19 32768 cc02.0ca0.0000 128.4

Sw3 
Sw3#show spanning-tree brief

VLAN1
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address cc00.0ca0.0000
Cost 19
Port 4 (FastEthernet0/3)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768
Address cc01.0ca0.0000
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1 128.2 128 19 FWD 19 32768 cc01.0ca0.0000 128.2
FastEthernet0/2 128.3 128 19 FWD 19 32768 cc01.0ca0.0000 128.3
FastEthernet0/3 128.4 128 19 FWD 0 32768 cc00.0ca0.0000 128.4
Sw4 
Sw4#show spanning-tree brief

VLAN1
Spanning tree enabled protocol ieee
Root ID Priority 32768
Address cc00.0ca0.0000
Cost 19
Port 2 (FastEthernet0/1)
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768
Address cc03.0ca0.0000
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 300

Interface Designated
Name Port ID Prio Cost Sts Cost Bridge ID Port ID
-------------------- ------- ---- ----- --- ----- -------------------- -------
FastEthernet0/1 128.2 128 19 FWD 0 32768 cc00.0ca0.0000 128.3
FastEthernet0/2 128.3 128 19 BLK 19 32768 cc01.0ca0.0000 128.2
FastEthernet0/3 128.4 128 19 BLK 19 32768 cc02.0ca0.0000 128.4

На основании вышеуказанного листинга делаем следующее заключение
GNS3 STP Cisco CCNA 640-802
 4. Проанализировать работу STP 

Sw1#debug spanning-tree events

Sw2#debug spanning-tree events

Sw3#debug spanning-tree events

Sw4#debug spanning-tree events

На свитче(бридже), который выбран ROOT данной топологии STP ( Sw1 ), почти одновременно отключаем два интерфейса ( FastEthernet 0/1 и FastEthernet 0/3 ). Почти одновременное отключение обеспечиваем вставкой из буфера обмена заранее заготовленных команд Cisco IOS CLI. Таким образом root-бридж временно пропадает из видимости для Sw2 и Sw3
Анализируем вывод команды debug spanning-tree events на Sw2, Sw3, Sw4.

Sw2#
*Mar 1 10:24:43.653: STP: VLAN1 Fa0/1 -> listening
*Mar 1 10:24:44.521: STP: VLAN1 we are the spanning tree root
*Mar 1 10:24:44.541: STP: VLAN1 heard root 32768-cc00.0ca0.0000 on Fa0/3
*Mar 1 10:24:44.545: current Root has 32768-cc02.0ca0.0000
*Mar 1 10:24:44.545: supersedes 32768-cc02.0ca0.0000
*Mar 1 10:24:44.549: STP: VLAN1 new root is 32768, cc00.0ca0.0000 on port Fa0/3, cost 38
*Mar 1 10:24:44.549: STP: VLAN1 sent Topology Change Notice on Fa0/3
*Mar 1 10:24:45.597: STP: VLAN1 Fa0/1 -> blocking

Sw3
*Mar 1 10:24:24.921: STP: VLAN1 heard root 32768-cc02.0ca0.0000 on Fa0/2
*Mar 1 10:24:24.925: current Root has 32768-cc00.0ca0.0000
*Mar 1 10:24:24.973: STP: VLAN1 we are the spanning tree root
*Mar 1 10:24:25.097: STP: VLAN1 heard root 32768-cc00.0ca0.0000 on Fa0/1
*Mar 1 10:24:25.097: current Root has 32768-cc01.0ca0.0000
*Mar 1 10:24:25.097: supersedes 32768-cc01.0ca0.0000
*Mar 1 10:24:25.097: STP: VLAN1 new root is 32768, cc00.0ca0.0000 on port Fa0/1, cost 38
*Mar 1 10:24:25.097: STP: VLAN1 sent Topology Change Notice on Fa0/1

Sw4
*Mar 1 10:24:53.125: STP: VLAN1 Fa0/3 -> listening
*Mar 1 10:24:53.225: STP: VLAN1 Fa0/2 -> listening
*Mar 1 10:24:54.165: STP: VLAN1 heard root 32768-cc02.0ca0.0000 on Fa0/3
*Mar 1 10:24:54.169: current Root has 32768-cc00.0ca0.0000
*Mar 1 10:24:54.241: STP: VLAN1 heard root 32768-cc01.0ca0.0000 on Fa0/2
*Mar 1 10:24:54.245: current Root has 32768-cc00.0ca0.0000
*Mar 1 10:24:54.253: STP: VLAN1 Topology Change rcvd on Fa0/3
*Mar 1 10:24:54.257: STP: VLAN1 sent Topology Change Notice on Fa0/1
*Mar 1 10:24:54.293: STP: VLAN1 Topology Change rcvd on Fa0/2
*Mar 1 10:25:08.145: STP: VLAN1 Fa0/3 -> learning
*Mar 1 10:25:08.249: STP: VLAN1 Fa0/2 -> learning
*Mar 1 10:25:23.189: STP: VLAN1 sent Topology Change Notice on Fa0/1
*Mar 1 10:25:23.189: STP: VLAN1 Fa0/3 -> forwarding
*Mar 1 10:25:23.293: STP: VLAN1 sent Topology Change Notice on Fa0/1
*Mar 1 10:25:23.293: STP: VLAN1 Fa0/2 -> forwarding

Листинг debug spanning-tree events и схема выше очень хорошо иллюстрирует действие алгоритмов протокола STP, в случае изменения топологии сети. 


9 комментариев:

Фай Ро комментирует...

я наверно покажусь надоедливым, но вот то что ты в конце применил для иллюстрации STP как бы не совсем правильно)... если отключить те порты которые ты указываешь на рисунке то получается hub-and-spoke топология, в которой никакого намека на петлю, а STP для того и нужен чтобы с петлями бороться... надо было лучше только старого рута отключить полностью из топологии и было бы понятно что они выбирают на основе сравнения у кого меньше BID...
PS зато ты проиллюстрировал одну неочевидную вещь...а именно STP (точнее PVST по умолчанию запущеный на свичах) работает на всех портах, будь то транк или порт доступа...

Dave комментирует...

Я очень даже не против того, чтобы были такие "надоедливые" читатели... Комментарии по делу, хотя я не со всем согласен... В частности, если взглянуть на последнюю картинку, но можно увидеть что при отключении портов FastEthernet 0/1 и FastEthernet 0/3 на руте, Sw2 и Sw3 теряют рута из виду на время, и сразу же начинают меряться своими BID-ами, что кстати тоже видно в листинге.

Фай Ро комментирует...

может быть я туплю но вот из твой посленей картинки нифига не понято, потому что она показывает ситуацию сразу после отключения портов на SW1. а вот что будет в итоге она не показывает... это уже приходится выискивать из листинга...
перевыборы происходят, но SW1 все равно остается рутом. и Alt порт будет только SW2 fa 0/1, все остальные будут форвардить...

Dave комментирует...

Я привел листинг для того, чтобы из него можно было понять поведение свитчей. В этих трех листинга очень хорошо видно поведение свитчей в момент схождения, как они начинают себя мнить рутами(Sw2 и Sw3), как сравнивают BID-ы (Sw3 и Sw4). Последняя часть лабы с debug spanning-tree events как раз для того чтобы все это посмотреть.

Анонимный комментирует...

Сижу с данной лабой разбираюсь...Тодько вот не понял одного: а где сам протокол то активируется??

Dave комментирует...

STP включен по умолчанию. RSTP нет возможности использовать с NM-16ESW.

Анонимный комментирует...

Я уже понял, когда схему собрал...А вообще спасибо Вам за материалы...Оч даже полезно и интересно.

Анонимный комментирует...

объясните, плиз, новичку для чего тут делается команда no ip domain lookup?

Dave комментирует...

Если набранные символы не узнаются оборудованием как команда или ее сокращение, то они воспринимаются как имя хоста к которому нужно подключиться по протоколу telnet. Эта команда это отключает.

Отправить комментарий