19 декабря 2010 г.

Лабораторная работа №21 Basic OSPF Configuration курса CISCO CCNA 640 - 802

Лабораторная работа CCNA GNS3
Целью данной лабораторной работы является базовая настройка протокола динамической маршрутизации Open Shortest Path First (OSPF), а также знакомство с основными аспектами его диагностики . Для выполнения данной лабораторной работы курса CCNA будет использоваться GNS3 / Cisco 2961. После выполнения лабораторной работы будут получены базовые навыки настройки и использования протокола OSPF на маршрутизаторах  CISCO.

Используемая топология


 План адресации
Лабораторная работа CCNA GNS3
1. Выполнить базовую конфигурацию R1,R2 и R3.
2. Выполнить конфигурацию сетевых интерфейсов R1,R2 и R3.
3. Выполнить конфигурацию OSPF для R1,R2 и R3.
4. Проверить конфигурацию OSPF 
5. Изменить OSPF Router ID 


1. Выполнить базовую конфигурацию R1,R2 и R3.
    Настроить  hostname.
    Отключить DNS lookup
    Настроить privileged EXEC mode password
    Настроить password для console0
    Настроить password для VTY 0 - 15
    Базовые настройки оборудования Cisco описаны в предыдущих лабораторных работах. 
    В качестве примера может быть использована  Лабораторная работа №19  

2. Выполнить конфигурацию сетевых интерфейсов R1,R2 и R3 согласно плана адресации.

R1 
R1(config)#interface Fa0/0
R1(config-if)#ip address 172.16.1.17 255.255.255.240
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface S0/0
R1(config-if)#clock rate 64000
R1(config-if)#encapsulation ppp
R1(config-if)#ip address 192.168.10.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface s0/1
R1(config-if)#encapsulation ppp
R1(config-if)#ip address 192.168.10.5 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#do copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

R2
R2(config)#interface Fa0/0
R2(config-if)#ip address 10.10.10.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface S0/0
R2(config-if)#encapsulation ppp
R2(config-if)#ip address 192.168.10.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface S0/1
R2(config-if)#clock rate 64000
R2(config-if)#encapsulation ppp
R2(config-if)#ip address 192.168.10.9 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#do copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

R3
R3(config)#interface Fa0/0
R3(config-if)#ip address 172.16.1.33 255.255.255.248
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface S0/0
R3(config-if)#clock rate 64000
R3(config-if)#encapsulation ppp
R3(config-if)#ip address 192.168.10.6 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface S0/1
R3(config-if)#encapsulation ppp
R3(config-if)#ip address 192.168.10.10 255.255.255.252
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#do copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

Для того чтобы быстро проверить сделанные настройки, можно воспользоваться командой Cisco CLI show ip interface brief, которая покажет установленные на интерфейса ip-адреса и статус интерфейсов.

3. Выполнить конфигурацию OSPF
R1
R1(config)#router ospf 1
R1(config-router)#network 172.16.1.16 0.0.0.15 area 0
R1(config-router)#network 192.168.10.0 0.0.0.3 area 0
R1(config-router)#network 192.168.10.4 0.0.0.3 area 0
R1(config-router)#end
R1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

R2
R2(config)#router ospf 1
R2(config-router)#network 10.10.10.0 0.0.0.255 area 0
R2(config-router)#network 192.168.10.0 0.0.0.3 area 0
R2(config-router)#network 192.168.10.8 0.0.0.3 area 0
R2(config-router)#end
R2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

R3 
R3(config)#router ospf 1
R3(config-router)#network 172.16.1.32 0.0.0.7 area 0
R3(config-router)#network 192.168.10.4 0.0.0.3 area 0
R3(config-router)#network 192.168.10.8 0.0.0.3 area 0
R3(config-router)#end
R3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

4. Проверить конфигурацию OSPF 

R1 
R1#show ip protocols
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 192.168.10.5
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
172.16.1.16 0.0.0.15 area 0
192.168.10.0 0.0.0.3 area 0
192.168.10.4 0.0.0.3 area 0

Reference bandwidth unit is 100 mbps
Routing Information Sources:
Gateway Distance Last Update
192.168.10.5 110 00:29:40
192.168.10.10 110 00:22:42
192.168.10.9 110 00:25:20
 Distance: (default is 110)

R2
R2#show ip protocols
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 192.168.10.9
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
10.10.10.0 0.0.0.255 area 0
192.168.10.0 0.0.0.3 area 0
192.168.10.8 0.0.0.3 area 0

Reference bandwidth unit is 100 mbps
Routing Information Sources:
Gateway Distance Last Update
192.168.10.5 110 01:01:50
192.168.10.10 110 00:57:16
192.168.10.9 110 00:59:51
Distance: (default is 110)

R3
R3#show ip protocols
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 192.168.10.10
Number of areas in this router is 1. 1 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
172.16.1.32 0.0.0.7 area 0
192.168.10.4 0.0.0.3 area 0
192.168.10.8 0.0.0.3 area 0

Reference bandwidth unit is 100 mbps
Routing Information Sources:
Gateway Distance Last Update
192.168.10.5 110 00:58:18
192.168.10.10 110 00:58:01
192.168.10.9 110 00:58:01
Distance: (default is 110)

5. Изменить OSPF Router ID
Изменить OSPF Router ID можно при помощи добавления loopback интерфейса с адресом, значения которого больше чем любого из назначенных интерфейсам маршрутизатора.

R1
R1(config)#interface loopback 0
R1(config-if)#ip address 10.1.1.1 255.255.255.255

R2
R2(config)#interface loopback 0
R2(config-if)#ip address 10.2.2.2 255.255.255.255

R3
R3(config)#interface loopback 0
R3(config-if)#ip address 10.3.3.3 255.255.255.255

Для того, чтобы новые параметры вступили в силу нужно перезапустить OSPF. Наиболее простой способ сохранить конфигурацию маршрутизатора, и выполнить команду reload.


Кроме того,  OSPF Router ID может быть установлен принудительно

R1(config)#router ospf 1
R1(config-router)#router-id 10.4.4.4
R1(config-router)#end

Для того, чтобы изменения вступили в силу нужно перезапустить OSPF. Это можно сделать при помощи команды clear

R1#clear ip ospf process

Проверить сделанные настройки можно через show ip protocols

Отменить предыдущие настройки

R1(config)#router ospf 1
R1(config-router)#no router-id 10.4.4.4
R1(config-router)#end

2 комментария:

Фай Ро комментирует...

надо было добавить еще два роутера в мультиэксесе и рассмотреть выборы DR/BDR, приоритет вручную задать)... тем более что вопросы на это в экзамене встречаются... тем более что серийники уже прошлый век)

Dave комментирует...

DR/BDR и приоритеты будут в следующей лабе.

Отправить комментарий