21 декабря 2010 г.

Лабораторная работа №22 Basic OSPF Configuration Часть 2 курса CISCO CCNA 640 - 802

Лабораторная работа CCNA GNS3
Целью данной лабораторной работы является базовая настройка протокола динамической маршрутизации Open Shortest Path First (OSPF), а также знакомство с основными аспектами его диагностики . Для выполнения данной лабораторной работы курса CCNA будет использоваться GNS3 / Cisco 2961. После выполнения лабораторной работы будут получены базовые навыки настройки и использования протокола OSPF на маршрутизаторах CISCO.
Данная лабораторная работа является продолжением Лабораторной работы №21 Basic OSPF Configuration курса CISCO CCNA 640 - 802. Используемая топология и план адресации идентичны. Для ее выполнения понадобится сохраненный проект GNS3 или же пред началом  выполнения этой лабораторной работы выполнить Лабораторную работу №21 ( как это было сделано мной ). Повторение никогда не бывает лишним.


1. Настройка параметра Cost протокола OSPF
2. Настройка распространения OSPF Default Route
3. Настройка дополнительных опций протокола OSPF

1. Настройка параметра Cost протокола OSPF
Предварительно проверить текущее значение cost для  serial - интерфейсов show ip ospf interface brief

R1 
R1#configure terminal
R1(config)#interface S0/0
R1(config-if)#bandwidth 64
R1(config-if)#exit
R1(config)#interface S0/1
R1(config-if)#bandwidth 64
R1(config-if)#exit

или

R1#configure terminal
R1(config)#interface S0/0
R1(config-if)#ip ospf cost 1562
R1(config-if)#exit
R1(config)#interface S0/1
R1(config-if)#ip ospf cost 1562
R1(config-if)#exit

R2
R2#configure terminal
R2(config)#interface S0/0
R2(config-if)#bandwidth 64
R2(config-if)#exit
R2(config)#interface S0/1
R2(config-if)#bandwidth 64
R2(config-if)#exit

или

R2#configure terminal
R2(config)#interface S0/0
R2(config-if)#ip ospf cost 1562
R2(config-if)#exit
R2(config)#interface S0/1
R2(config-if)#ip ospf cost 1562
R2(config-if)#exit

R3
R3#configure terminalR3(config)#interface S0/0
R3(config-if)#bandwidth 64
R3(config-if)#exit
R3(config)#interface S0/1
R3(config-if)#bandwidth 64
R3(config-if)#exit

или

R3#configure terminal
R3(config)#interface S0/0
R3(config-if)#ip ospf cost 1562
R3(config-if)#exit
R3(config)#interface S0/1
R3(config-if)#ip ospf cost 1562
R3(config-if)#exit

Проверить изменение параметра  cost командой  show ip ospf interface brief

2. Настройка распространения OSPF Default Route 
Предварительно проверить текущие значения таблицы маршрутизации на R1 и R2 командой show ip route.  
На R1 создаем интерфейс loopback 1 с адресом 172.30.1.1 и добавляем default route через интерфейс loopback 1.    

R1#configure terminal
R1(config)#interface loopback 1
R1(config-if)#ip address 172.30.1.1 255.255.255.252
R1(config-if)#exit
R1(config)#ip route 0.0.0.0 0.0.0.0 loopback1
R1(config)#exit

Добавляем статические маршруты в обновления OSPF на R1

R1(config)#router ospf 1
R1(config-router)#default-information originate
R1(config-router)#end

Проверить результат командой show ip route
 

3. Настройка дополнительных опций протокола OSPF 

Изменение параметра reference-bandwidth используемого для расчета значения OSPF cost.

Предварительно проверить текущее занчение параметра OSPF cost командой show ip route

R1
R1(config)#router ospf 1
R1(config-router)#auto-cost reference-bandwidth 10000
R1(config-router)#

R2
R2(config)#router ospf 1
R2(config-router)#auto-cost reference-bandwidth 10000
R2(config-router)#

R3
R3(config)#router ospf 1
R3(config-router)#auto-cost reference-bandwidth 10000
R3(config-router)#

Проверить результат командой  show ip route

Изменение значений таймеров протокола OSPF 

Предварительно проверить текущее значение Dead Time counter командой show ip ospf neighbor, а также знчения hello-interval и dead-interval для интерфейса Serial 0/0 командой show ip ospf interface Serial 0/0 

R1
R1(config)#interface S0/0
R1(config-if)#ip ospf hello-interval 5
R1(config-if)#ip ospf dead-interval 20

Как только истекут 20 секунд, появится сообщение

*Mar 1 02:00:03.127: %OSPF-5-ADJCHG: Process 1, Nbr 10.2.2.2 on Serial0/0 from FULL to DOWN, Neighbor Down: Dead timer expired

Это обусловлено тем, что значения параметров  hello-interval и dead-interval должны совпадать на обоих концах линка. 

R2

R2(config)#interface S0/0
R2(config-if)#ip ospf hello-interval 5
R2(config-if)#ip ospf dead-interval 20

Сразу после установки нового значения для hello-interval появится сообщение

*Mar 1 02:06:44.595: %OSPF-5-ADJCHG: Process 1, Nbr 10.1.1.1 on Serial0/0 from LOADING to FULL, Loading Done

Проверить новые значения Dead Time counter командой show ip ospf neighbor, а также знчения hello-interval и dead-interval для интерфейса Serial 0/0 командой show ip ospf interface Serial 0/0 на R1 и R2.

Комментариев нет:

Отправить комментарий