25 декабря 2010 г.

Лабораторная работа №23 Configure OSPF on a Multi-access Network курса CISCO CCNA 640 - 802

Лабораторная работа CCNA GNS3
Целью данной лабораторной работы является настройка и диагностика протокола динамической маршрутизации Open Shortest Path First (OSPF) в Multi-access сети. Для выполнения данной лабораторной работы курса CCNA будет использоваться GNS3 / Cisco 2961. После выполнения лабораторной работы будут получены навыки настройки и использования протокола OSPF для использования в Multi-access сети.


Используемая топология

Лабораторная работа CCNA GNS3

План адресации

Лабораторная работа CCNA GNS3

1. Выполнить базовую конфигурацию R1,R2 и R3.
2. Настройка сетевых параметров согласно плана адресации для R1, R2 и R3.  
3. Настроить параметры протокола OSPF для R3, R2 и R1. 
4. Настроить OSPF Priority для определения DR и BDR. 

1. Выполнить базовую конфигурацию R1,R2 и R3.
    Настроить hostname.
    Отключить DNS lookup
    Настроить privileged EXEC mode password
    Настроить password для console0
    Настроить password для VTY 0 - 15
    Базовые настройки оборудования Cisco описаны в предыдущих лабораторных работах.
    В качестве примера может быть использована Лабораторная работа №19

 2.  Настройка сетевых параметров согласно плана адресации для R1, R2 и R3
R1
R1#configure terminal
R1(config)#interface Fa0/0
R1(config-if)#ip address 192.168.1.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#interface lo0
R1(config-if)#ip address 192.168.31.11 255.255.255.255
R1(config-if)#end
R1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

R2
R2>enable
R2#configure terminal
R2(config)#interface Fa0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface lo0
R2(config-if)#ip address 192.168.31.22 255.255.255.255
R2(config-if)#end
R2#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

R3
R3>enable
R3#configure terminal
R3(config)#interface Fa0/0
R3(config-if)#ip address 192.168.1.3 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface lo0
R3(config-if)#ip address 192.168.31.33 255.255.255.255
R3(config-if)#end
R3#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Проверить правильность выполненных настроек командой show ip interface brief, а также командой ping.

3. Настроить параметры протокола OSPF для R3, R2 и R1.  
Настройка производится в обратном порядке для того, чтобы DR и BDR. соответствовали Router ID, а не очередности добавления OSPF роутера в сеть.

R3
R3(config)#router ospf 1
R3(config-router)#network 192.168.1.0 0.0.0.255 area 0
R3(config-router)#end

R2
R2(config)#router ospf 1
R2(config-router)#network 192.168.1.0 0.0.0.255 area 0
R2(config-router)#end

R1 
R1(config)#router ospf 1
R1(config-router)#network 192.168.1.0 0.0.0.255 area 0
R1(config-router)#end

Проверить выполненные настройки командой show ip ospf interface Fa0/0 на R3, R2 и R1

R3
R3#show ip ospf interface F0/0
FastEthernet0/0 is up, line protocol is up
    Internet Address 192.168.1.3/24, Area 0
    Process ID 1, Router ID 192.168.31.33, Network Type BROADCAST, Cost: 10
    Transmit Delay is 1 sec, State DR, Priority 1
    Designated Router (ID) 192.168.31.33, Interface address 192.168.1.3
    Backup Designated router (ID) 192.168.31.22, Interface address 192.168.1.2

R2
R2#show ip ospf interface Fa0/0
FastEthernet0/0 is up, line protocol is up
    Internet Address 192.168.1.2/24, Area 0
    Process ID 1, Router ID 192.168.31.22, Network Type BROADCAST, Cost: 10
    Transmit Delay is 1 sec, State BDR, Priority 1
    Designated Router (ID) 192.168.31.33, Interface address 192.168.1.3
    Backup Designated router (ID) 192.168.31.22, Interface address 192.168.1.2

R1
R1#show ip ospf interface Fa0/0
FastEthernet0/0 is up, line protocol is up
    Internet Address 192.168.1.1/24, Area 0
    Process ID 1, Router ID 192.168.31.11, Network Type BROADCAST, Cost: 10
    Transmit Delay is 1 sec, State DROTHER, Priority 1
    Designated Router (ID) 192.168.31.33, Interface address 192.168.1.3
    Backup Designated router (ID) 192.168.31.22, Interface address 192.168.1.2
   
На роутере R1 выполнить команду show ip ospf neighbor

R1#show ip ospf neighbor

Neighbor ID           Pri           State              Dead Time          Address                Interface
192.168.31.22         1        FULL/BDR     00:00:38            192.168.1.2         FastEthernet0/0
192.168.31.33         1        FULL/DR        00:00:35            192.168.1.3         FastEthernet0/0

4. Настроить OSPF Priority для определения DR и BDR
Максимальное значение параметра Priority 255.

R1
R1(config)#interface Fa0/0
R1(config-if)#ip ospf priority 255
R1(config-if)#end

R2

R2(config)#interface F0/0
R2(config-if)#ip ospf priority 0
R2(config-if)#end

R3
R3(config)#interface Fa0/0
R3(config-if)#ip ospf priority 100
R3(config-if)#end

Для инициализации процесса выбора DR и BDR отключить FastEthernet 0/0 на R1,R2 и R3

R1
R1(config)#interface F0/0
R1(config-if)#shutdown
R1(config-if)#

*Mar 1 02:52:11.847: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.22 on FastEthernet0/0 from 2WAY to DOWN, Neighbor Down: Interface down or detached
*Mar 1 02:52:11.851: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.33 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
R1(config-if)#

R2
*Mar 1 02:52:05.907: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.11 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired
 

R2(config)#interface F0/0
R2(config-if)#shutdown
R2(config-if)#

*Mar 1 02:52:21.875: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.33 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Interface down or detached

R3
*Mar 1 02:51:20.819: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.11 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired
*Mar 1 02:52:13.375: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.22 on FastEthernet0/0 from FULL to DOWN, Neighbor Down: Dead timer expired

R3(config)#interface F0/0
R3(config-if)#shutdown

Включить FastEthernet 0/0 на R2,R1 и R3

R2
R2(config-if)#no shutdown
R2(config-if)#

*Mar 1 03:05:29.763: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.11 on FastEthernet0/0 from LOADING to FULL, Loading Done
R2(config-if)#
*Mar 1 03:05:33.239: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.33 on FastEthernet0/0 from LOADING to FULL, Loading Done

R1
R1(config-if)#no shutdown
R1(config-if)#

*Mar 1 03:06:12.551: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.22 on FastEthernet0/0 from LOADING to FULL, Loading Done
R1(config-if)#
*Mar 1 03:06:15.907: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.33 on FastEthernet0/0 from LOADING to FULL, Loading Done

R3
R3(config-if)#no shutdown
R3(config-if)#

*Mar 1 03:04:48.007: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.11 on FastEthernet0/0 from LOADING to FULL, Loading Done
*Mar 1 03:04:48.123: %OSPF-5-ADJCHG: Process 1, Nbr 192.168.31.22 on FastEthernet0/0 from LOADING to FULL, Loading Done

Проверяем полученный результат командой show ip ospf neighbor на R2

R2(config-if)#do show ip ospf neighbor

Neighbor ID           Pri                   State             Dead Time             Address            Interface
192.168.31.11          255           FULL/DR         00:00:30              192.168.1.1      FastEthernet0/0
192.168.31.33         100            FULL/BDR       00:00:35             192.168.1.3      FastEthernet0/0

11 комментариев:

Анонимный комментирует...

Dave,спасибо,хорошим делом занимаешься! Неплохо было бы добавить материал по распределению (redistribute)маршрутов.Нужная вещь

Dave комментирует...

В рамках курса CCNA изучается redistribute статических маршрутов протоколом OSPF. Это есть в лабораторной работе №22.

Анонимный комментирует...

Имеется ввиду настройка взаимного перераспределения, когда разные протоколы настроены на роутерах. Например OSPF и RIP, EIGRP и RIP,OSPF и EIGRP. Заранее спасибо

Dave комментирует...

Понял. Тема интересная.

Анонимный комментирует...

уважаемый Dave, сделайте пож-та пост про redistribute OSPF и RIPv2

Dave комментирует...

К сожалению, тема перераспределения маршрутов из одного протокола динамической маршрутизации в другой (из RIP -> OSPF или RIP -> EIGRP) выходит за рамки курса Cisco CCNA. Повторюсь тема, интересная, но пока мной не будет рассматриваться. так как не хватает времени на основной материал курса.

Анонимный комментирует...

А зачем для инициализации отключать интефейсы, нельзя ли просто очистить ospf procees, тогда протокол выберет себе DR?. И еще вопрос к вам, сайт очень нужный, так как есть план подготовки, и меньше каши в голове. Собственно вопрос, сами лабы вы сами придумывали или это официальные, которые попадаются на экзаменах?

Dave комментирует...

Интерфейсы тушил, так как именно так было написано в сценарии лабораторной работы.
Это лабораторные работы из разных пособий которые я читал и читаю. Т.е. если где-то попадается интересная лаба, то я ее выполняю. Иногда еще и публикую. Это не все лабораторные работы, но все из официальных пособий. Иногда усложняю топологии. Чтобы интересней было...

Анонимный комментирует...

интересно все тут!мне нравиться..очень помогает в объяснении и в подготовке к сдаче экзаменов!побольше бы различных ситуаций!

Анонимный комментирует...

Огромное спасибо за такой проделанный труд! Скажите, это примерно похожие лабы, которые попадаются на экзамене? или же те что дают в пособиях мало отношения имеют к реальному тесту? Есть конечно экзаменационные дампы, но всё-таки, считаю, надо самому немного понимать что делаешь.

Dave комментирует...

Не совсем. Это лабораторные работы для лучшего усвоения практической части курса. Подобные лабораторные работы также позволяют легче отвечать на вопросы экзамена касающиеся практической стороны темы.
Сдать экзамен, используя дампы несложно, но в реальной жизни это не даст ни каких-либо знаний ни малейшего опыта.

Отправить комментарий