31 августа 2010 г.

Лабораторная работа №12 Configure Serial Interfaces and Static Route курса CISCO CCNA 640 - 802

CISCO CCNA 640 - 802 Лабораторная работа №12 Configure Serial Interfaces and Static Route
Целью данной лабораторной работы является настройка serial-интерфейсов маршрутизатора, а также статической маршрутизации на маршрутизаторах CISCO. При выполнении будет использоваться GNS3 / Cisco 2961. После выполнения лабораторной работы будут получены базовые навыки настройки serial-интерфейсов оборудования CISCO, а также закреплены навыки настройки статической маршрутизации.
Топология, которая будет использоваться при выполнении лабораторной работы.
1. Провести начальную конфигурацию маршрутизаторов R1, R2, R3. 
2. Настроить интерфейсы маршрутизаторов R1, R2, R3
3. Добавить статические маршруты в таблицы маршрутизаторов R1, R2, R3
4. Проверить  сделанные настройки.

1. Провести начальную конфигурацию маршрутизаторов R1, R2, R3. 

R1
Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#no ip domain-lookup
R1(config)#line console 0
R1(config-line)#logging synchronous

R2 
Router>enable
Router#configure terminal
Router(config)#hostname R2
R2(config)#no ip domain-lookup
R2(config)#line console 0
R2(config-line)#logging synchronous

R3
Router>enable
Router#configure terminal
Router(config)#hostname R3
R3(config)#no ip domain-lookup
R3(config)#line console 0
R3(config-line)#logging synchronous

2. Настроить интерфейсы маршрутизаторов R1, R2, R3 

R1
R1(config)#interface FastEthernet0/0
R1(config-if)#ip address 172.16.4.1 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface Serial 0/0
R1(config-if)#clock rate 64000
R1(config-if)#encapsulation ppp
R1(config-if)#ip address 172.16.2.254 255.255.255.0
R1(config-if)#no shutdown
R1(config-if)#

R2
R2(config)#interface Serial 0/0
R2(config-if)#encapsulation ppp
R2(config-if)#ip address 172.16.2.1 255.255.255.0
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface Serial 0/1
R2(config-if)#encapsulation ppp
R2(config-if)#ip address 172.16.1.1 255.255.255.0
R2(config-if)#no shutdown

R3
R3(config)#interface FastEthernet0/0
R3(config-if)#ip address 172.16.3.1 255.255.255.0
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface Serial 0/0
R3(config-if)#clock rate 64000
R3(config-if)#encapsulation ppp
R3(config-if)#ip address 172.16.1.254 255.255.255.0
R3(config-if)#no shutdown
3. Добавить статические маршруты в таблицы маршрутизаторов R1, R2, R3

R1
R1(config)#ip route 0.0.0.0 0.0.0.0 Serial 0/0

R2
R2(config)#ip route 172.16.4.0 255.255.255.0 Serial 0/0
R2(config)#ip route 172.16.3.0 255.255.255.0 Serial 0/1

R3
R3(config)#ip route 0.0.0.0 0.0.0.0 Serial 0/0

Необходимо обратить внимание на тот факт, что при добавлении маршрута через serial-интерфейс возможно указывать не IP-адрес шлюза, а только имя serial-интерфейса. Такое добавление статических маршрутов невозможно в multiple-access сетях, таких как Ethernet, FrameRelay. Мне приходилось читать о случаях, когда на этом "прокалывались" претенденты на звание CCNA

4. Проверить  сделанные настройки.
R1>ping 172.16.3.1

R3>ping 172.16.4.1

Успешное прохождение ICMP-пакетов из одного конца сети в другой говорит об успешно выполненном конфигурировании маршрутизаторов.




16 комментариев:

longleyge комментирует...

интересно, откуда информация насчет того, что невозможно прописывать в multiple-access сетях?
например в gns3 3600 можно указать интерфейс:
e0/0
Router(config)#ip route 0.0.0.0 0.0.0.0 e0/0
или
Router(config)#ip route 192.168.1.0 255.255.255.0 e0/0

Dave комментирует...

Согласен, правильней будет написать "недопустимо".

Анонимный комментирует...

Хотелось бы узнать откуда Вы взяли информацию о "недопустимости" и на чем базируется сие утверждение.

Dave комментирует...

Книга Cisco Press Interconnecting Cisco Network Devices, Part 1 (ICND1): CCNA Exam 640-802 and ICND1 Exam 640-822
Страница 402 Таблица 5-3 "ip route Parameters"
Написано следующее:
"Name of the interface to use to get to the destination network.
The interface should be a point-to-point interface. The
command does not work properly if the interface is multiaccess
(for example, a shared media Ethernet interface)."
Как-то так. Хотя в сетях Ethernet такие маршруты работают в обычных условиях. Но наверняка существуют ситуации, когда они будут работать неправильно или не будут работать вообще.
Что касается самого утверждения и его отношения к экзамену, то если автор книги сделал на этом акцент, то лучше запомнить.

Anton комментирует...

Сие утверждение основывается на том, что даже если с другой стороны мультиаксес среды отвалится интерфейс, то маршрут в таблице маршрутизации останется. В итоге это приведет к потерям трафика. С другой стороны линк эзернет тоже вполне может быть поинт-ту-поинт.
Это я к чему. Тут стоит поправить акцент на тип соединения (п-т-п, п-т-м или мультиаксес), а не линейный протокол (эзернет или хдлц).

Анонимный комментирует...

В дополнение:

> R3(config-if)#clock rate 64000
clock rate задаётся только на serial-интерфейсе со статусом кабеля DCE (статус можно посмотреть: show controllers serial x/y, x и y - номер serial-порта. Например, 0/0). Проще сразу прописывать на всех интерфейсах (что бы не заморачиваться), но пройдёт ли это на экзамене - не знаю.

Dave комментирует...

Идея сама по себе хороша, но во всех лабораторных работах, когда в топологии маршрутизатор указывается как DCE, то только в его листинге указывается clock rate, и использование той же команды на устройстве DTE могут расценить как элемент незнания некоторых аспектов теории. К тому же, результат выполнения экзаменационной лабораторной работы оценивается по полученному конфигурационному файлу.

Pavel комментирует...

Необходимо обратить внимание на тот факт, что при добавлении маршрута через serial-интерфейс возможно указывать не IP-адрес шлюза, а только имя serial-интерфейса. Такое добавление статических маршрутов невозможно в multiple-access сетях, таких как Ethernet, FrameRelay. Мне приходилось читать о случаях, когда на этом "прокалывались" претенденты на звание CCNA.

Такое добавление статических маршрутов ВОЗМОЖНО в multiple-access сетях, таких как Ethernet. Смысл в том, чтобы маршрутизаторе - получателе был включен Proxy ARP и настроен маршрут по умолчанию, тогда все будет работать. От того что мы указываем как выходной интерфейс, зависит структура ARP - пакета. Если мы указываем конкретный адрес соседнего роутера, то ARP пакет спросит MAC адрес соседа, и после этого доставит ему пакет. Если мы укажем выходной интерфейс, то роутер будет считать что та подсеть которую мы указали является direct connect-ом и будет отправлять ARP спрашивая не адрес соседнего маршрутизатора, а адрес конечного получателя!!! Соседний роутер, получая этот запрос, и имея маршрут 0.0.0.0 0.0.0.0 =неважно интерфейс или ip для выхода= (в Ethernt) думает, что знает маршруты ко всем сетям, соответственно он отправляет ARP ответ обратно со своим MAC адресом, для того, чтобы его сосед отправил пакет ему. Proxy ARP включен по умолчанию, но отключается если выполнить autosecure. На словах это сложно объяснить, а добавлять иллюстрации здесь нельзя. Попробуйте эти два варианта в Packet Tracer и все увидите наглядно. Заглядывайте только в структуру пакета внимательно. В Serial линках нет ни ARP-па ни MAC адресов, там если указать выходной интерфейс, то пакет автоматически отправится через линк, без всяких ARP-ов.

Dave комментирует...

Все правильно. Так и есть. Некоторое время назад моделировал эту ситуацию в GNS3 + Wireshark, и вместе с Anton мы эту тему обсудили. Но не смотря на то, что такие маршруты будут работать, подобный способ указания маршрутов в MA сетях отношу к категории нежелательных. Есть вероятность того, что в некоторой ситуации сеть себя поведет неожиданным образом.
Применительно к экзамену CCNA - автор книги скорее всего не просто так сделал на этом акцент.

Pavel комментирует...

За был добавить. В отличие от Ethernet с Proxy ARP, во Frame Relay работать не будет. Логика роутера примерно такова:
1.The router encapsulates the data into an IP packet.
2.The router looks up the destination IP address in the routing table.
3.The routing table finds a routing entry to the destination IP address.
4.The destination routing entry is connected static route. Это самое место - логика проста, роутер думает, что сеть которую мы указали с помощью команды ip route X.X.X.X Y.Y.Y.Y interface_to_exit, являетс direct connect-ом, поэтому он выполняет: The router sets destination as the next-hop.
5. The packet is unicast. (В нашем случае обычный ping)The device looks up in the Frame Relay map table for the DLCI number.
6. The packet's destination IP address is not found in the Frame Relay map table. The device drops the packet.
Жаль здесь нельзя прикреплять файли и картинки, обсуждение было бы намного интереснее.

Dave комментирует...

Я ткнул в ваш профиль, и обнаружил наличие пустого блога на платформе blogger. Думаю, если разместить там публикацию по этой теме, то можно здесь в комментариях дать на нее ссылку. Это будет очень полезно другим читателям.

Pavel комментирует...

Почему тебе самому не разместить ссылку в своем блоге? Если нужны картинки и конфиги для размещения скажи мне куда их скинуть. Инфа я тоже считаю довольно полезная.

Dave комментирует...

Нет вопросов. ccnastepbystep[ат]gmail.com

Pavel комментирует...

Я забыл про point-to-point subintreface во frame-relay, там отсутствует map-таблица. Т.е. при вводе show frame-relay map не будет отображения соответствия ip - dlci, соответственно логика роутера на шаге 5 может поменяться, надо будет попробовать. Это все уже далеко выходит за рамки CCNA.

Alex комментирует...

если в CPT, то clock rate нужно поднимать на R2 s0/0/1, у меня с поднятым на R3 не работало!

Dave комментирует...

Странно. При таком соединении один интерфейс должен быть DCE и на нем указывается clock rate. Я выбрал интерфейсы на R1 и R3, но это не принципиально, можно и на R2 оба интерфейса настроить как DCE. Главное чтобы с одной стороны serial-линка был указан clock rate. Но ситуация с CPT мне не совсем ясна, если честно.

Отправить комментарий